Bug 1410163 - crash due to not finding libnss_wins.so.2 dependencies in getaddrinfo
Summary: crash due to not finding libnss_wins.so.2 dependencies in getaddrinfo
Keywords:
Status: CLOSED DUPLICATE of bug 1393050
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 16:09 UTC by Paulo Andrade
Modified: 2017-01-04 16:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 16:23:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1410154 None ASSIGNED glibc: Incomplete rollback of dynamic linker state on linking failure 2019-09-11 16:12:12 UTC

Description Paulo Andrade 2017-01-04 16:09:55 UTC
Steps to reproduce:

* Base 7.3 install
* yum install samba-winbind
* edit /etc/nsswitch.conf to show the following host line:

    hosts:      files wins dns myhostname

* systemctl start winbind
* ping redhat.com

  "Quick fix" could be to have /usr/lib64/samba/ in
LD_LIBRARY_PATH.

  Should also be fixable in libnss_wins.so.2 link.

$ ldd /lib64/libnss_wins.so.2
	linux-vdso.so.1 =>  (0x00007ffefcf2d000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f683cd2a000)
	libwbclient.so.0 => /lib64/libwbclient.so.0 (0x00007f683cb1b000)
	libreplace-samba4.so => not found
	libc.so.6 => /lib64/libc.so.6 (0x00007f683c759000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f683d15e000)
	libwinbind-client-samba4.so => /usr/lib64/samba/libwinbind-client-samba4.so (0x00007f683c555000)
	libreplace-samba4.so => /usr/lib64/samba/libreplace-samba4.so (0x00007f683c351000)

Comment 1 Andreas Schneider 2017-01-04 16:23:27 UTC

*** This bug has been marked as a duplicate of bug 1393050 ***

Comment 2 Andreas Schneider 2017-01-04 16:24:52 UTC
zstream updated is scheduled for Jan 17th.


Note You need to log in before you can comment on or make changes to this bug.