Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410195 - [RFE] Ability to choose the name of the Ceph cluster
Summary: [RFE] Ability to choose the name of the Ceph cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
Derek
URL:
Whiteboard:
: 1429605 (view as bug list)
Depends On: 1635346
Blocks: 1413723 1442136 1466008 1481685 1539034 1659607
TreeView+ depends on / blocked
 
Reported: 2017-01-04 17:47 UTC by seb
Modified: 2020-04-15 15:03 UTC (History)
16 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.0.0-0.20180710202746.d2994ca.el7ost
Doc Type: Enhancement
Doc Text:
Heat templates now include the `CephClusterName` parameter. This parameter enables you to customize the Ceph cluster name, which you might need to do if you use an external Ceph cluster or a Ceph RBDMirror.
Clone Of:
Environment:
Last Closed: 2019-01-11 11:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 541664 0 None MERGED Allows for configuration of the Ceph cluster name 2021-02-08 07:21:00 UTC
OpenStack gerrit 543435 0 None MERGED Allow for customization of the Ceph cluster name for Cinder 2021-02-08 07:20:59 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:47:58 UTC

Description seb 2017-01-04 17:47:08 UTC
Description of problem:

Presently, TripleO is not capable of deploying a Ceph cluster with a name different than the default "ceph". In order to work properly with RBD mirroring, we need to have the ability to deploy Ceph clusters with a dedicated name. In a DR scenario, we might have a "primary" cluster and a "secondary" cluster on the DR site.

puppet-ceph is already capable of doing this, so we only need to expose this capability up to TripleO.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jason Dillaman 2017-01-04 19:44:25 UTC
Note: the rbd-mirror daemon really does *not* require different cluster names. It only requires two "ceph.conf" configuration files to talk to the local and remote cluster. Therefore, you could just as easily copy remote cluster's ceph.conf to "remote.conf" and just use "remote" as the name of the remote ceph cluster -- since the cluster name is actually only used for locating the configuration file.

Comment 2 seb 2017-01-05 14:19:42 UTC
Right, I should have marked this as optional, I just believe that from an operational perspective it might be valuable to have this. Especially in the context of multisite.

What about keys though? I guess we need to change the path of the admin key (if we want to use this one) in the ceph.conf, right?

Comment 3 Jason Dillaman 2017-01-05 14:29:51 UTC
In a perfect world, it would be great if ceph-ansible would create a new user for rbd-mirror so that it didn't use the admin keyring (with full permissions for everything for both the local and remote clusters).

You are correct that you would want to update the keyring within the copied remote ceph.conf (or preferably blank it out so that it locates it automatically by cluster and user name [1]).

[1] http://docs.ceph.com/docs/master/rados/operations/user-management/#keyring-management

Comment 7 seb 2017-06-13 13:16:25 UTC
Depending on the outcome yes, the situation is tracked here: https://bugzilla.redhat.com/show_bug.cgi?id=1459861

Comment 8 seb 2017-06-13 16:32:37 UTC
Alright, it seems that it has been confirmed here https://bugzilla.redhat.com/show_bug.cgi?id=1459861, we don't want to expose cluster names in the next ceph-ansible release. This release will be used by OSP12, thus we can abandon this.

Instead, we need a right documentation to configure mirroring. This is mainly a post-deployment task.

I'm not closing this, we can potentially track the doc here but we can stop the development.

Comment 10 Giulio Fidente 2018-02-07 10:59:20 UTC
I guess this is going to need a few changes in the puppet modules too, we'll probably work it with multiple submissions from different people.

Comment 11 Giulio Fidente 2018-02-09 08:59:51 UTC
*** Bug 1429605 has been marked as a duplicate of this bug. ***

Comment 14 Yogev Rabl 2018-11-29 13:16:47 UTC
verified

Comment 18 errata-xmlrpc 2019-01-11 11:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.