Bug 1466008 - [RFE] Support multiple Ceph clusters deployment via Director
Summary: [RFE] Support multiple Ceph clusters deployment via Director
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: 15.0 (Stein)
Assignee: John Fulton
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1759890 (view as bug list)
Depends On: 1410195 1623683
Blocks: 1412374 1415266 1476902 1659607 1225775 1309550 1459148 1466391 1539034
TreeView+ depends on / blocked
 
Reported: 2017-06-28 17:03 UTC by Bertrand
Modified: 2020-02-20 13:44 UTC (History)
29 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190620180423.14f4f23.el8ost
Doc Type: Technology Preview
Doc Text:
Director can now deploy different, isolated Ceph clusters into different Edge zones by creating an overcloud composed of multiple heat stacks. For example, director can deploy an overcloud that consists of a heat stack for the control plane (Controller nodes) and multiple additional stacks for Edge zones (Computes and Ceph Storage nodes or Compute and HCI nodes).
Clone Of:
: 1722593 (view as bug list)
Environment:
Last Closed: 2020-02-20 11:40:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bertrand 2017-06-28 17:03:57 UTC
Today, in order to deploy multiple Ceph clusters in an Openstack environment, 
Ceph clusters need to be deployed "externally" using other tools like ceph-ansible/ceph-deploy.

The ask here is to allow multiple Ceph clusters deployment via Director so as to simplify tooling to manage the cloud solution. Operation teams do not need to deal with two tools but a single one.

Comment 27 Gregory Charot 2019-08-12 15:59:59 UTC
Moving to 15.z since RHCSv4 won't be supported at OSP15 GA date.

Comment 34 Shelley Dunne 2019-09-19 18:29:54 UTC
Re-setting Target Milestone z1 to --- to begin the 15z1 Maintenance Release.

Comment 37 Giulio Fidente 2019-10-23 13:31:29 UTC
*** Bug 1759890 has been marked as a duplicate of this bug. ***

Comment 42 Lon Hohberger 2020-02-13 11:40:53 UTC
According to our records, this should be resolved by openstack-tripleo-heat-templates-10.6.2-0.20191113030444.fc5ca30.el8ost.  This build is available now.

Comment 43 Yogev Rabl 2020-02-19 14:50:53 UTC
Tested and verified

Comment 44 Yogev Rabl 2020-02-19 14:51:33 UTC
Tested and verified

Comment 45 Yogev Rabl 2020-02-19 14:51:42 UTC
Tested and verified


Note You need to log in before you can comment on or make changes to this bug.