Bug 1410355 - Remove-brick rebalance failed while rm -rf is in progress
Summary: Remove-brick rebalance failed while rm -rf is in progress
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1405000
Blocks: 1408115 1408138 1408414 1410764
TreeView+ depends on / blocked
 
Reported: 2017-01-05 09:35 UTC by Susant Kumar Palai
Modified: 2017-03-06 17:42 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1405000
: 1410764 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:42:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-06 08:46:58 UTC
REVIEW: http://review.gluster.org/16328 (dht/rebalance: remove errno check for failure detection) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2017-01-06 10:25:47 UTC
COMMIT: http://review.gluster.org/16328 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 451ca272d12f2d49522c845d53585520f71525f8
Author: Susant Palai <spalai@redhat.com>
Date:   Thu Jan 5 11:46:20 2017 +0530

    dht/rebalance: remove errno check for failure detection
    
    BUG: 1410355
    Change-Id: I867419ca36a81ef7209e6911a46c1c2c898b8eab
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/16328
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.