Bug 1410764 - Remove-brick rebalance failed while rm -rf is in progress
Summary: Remove-brick rebalance failed while rm -rf is in progress
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1405000 1410355
Blocks: 1408115 1408138 1408414
TreeView+ depends on / blocked
 
Reported: 2017-01-06 12:05 UTC by Susant Kumar Palai
Modified: 2017-01-16 12:28 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.8.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410355
Environment:
Last Closed: 2017-01-16 12:28:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-06 12:06:02 UTC
REVIEW: http://review.gluster.org/16348 (dht/rebalance: remove errno check for failure detection) posted (#1) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2017-01-08 11:03:55 UTC
COMMIT: http://review.gluster.org/16348 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit e509aebc2d6aacd25d9b7530c8722c3475eea055
Author: Susant Palai <spalai@redhat.com>
Date:   Thu Jan 5 11:46:20 2017 +0530

    dht/rebalance: remove errno check for failure detection
    
    > BUG: 1410355
    > Change-Id: I867419ca36a81ef7209e6911a46c1c2c898b8eab
    > Signed-off-by: Susant Palai <spalai@redhat.com>
    > Reviewed-on: http://review.gluster.org/16328
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit 451ca272d12f2d49522c845d53585520f71525f8)
    
    Change-Id: If05094346fc1fc48f4982db6a195740171ae2fad
    BUG: 1410764
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/16348
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2017-01-16 12:28:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.8, please open a new bug report.

glusterfs-3.8.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-January/000064.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.