Bug 1410663 - [RFE] Keystone integration with LDAP / AD via Director
Summary: [RFE] Keystone integration with LDAP / AD via Director
Keywords:
Status: CLOSED DUPLICATE of bug 1259035
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jiri Stransky
QA Contact: Arik Chernetsky
URL:
Whiteboard:
: 1412345 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 03:33 UTC by Shinobu KINJO
Modified: 2020-03-11 15:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-07 17:39:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shinobu KINJO 2017-01-06 03:33:24 UTC
Description of problem:

We have provided the feature of integration of keystone with LDAP/AD as an external back-end since OSP7. [1], [2], [3], [4]

This feature works well when the customers configured their Stack system manually.

But after integration, updating overcloud nodes via Director failed.

Since many customers are interested in this integration and they would like to make it via Director, it's very important for us to make it possible via Director.

It seems to me that OSP8 does not have this feature (maybe OSP9 as well?).

It would be better to let the customers know when this feature will come out officially.

Regards,

## Guides ##
[1] https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/7/paged/integrate-with-identity-service/
[2] https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/paged/integrate-with-identity-service/
[3] https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/paged/integrate-with-identity-service/
[4] https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/integrate-with-identity-service/

## BZ ##
[5] https://bugzilla.redhat.com/show_bug.cgi?id=1311993

## External ##
[6] https://adam.younglogic.com/2016/05/identity-newton/
* Thanks to ayoung!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nathan Kinder 2017-03-03 17:40:56 UTC
*** Bug 1412345 has been marked as a duplicate of this bug. ***

Comment 2 Nathan Kinder 2017-06-07 17:39:37 UTC
This feature is expected to land in OSP12.  Closing this as a duplicate of the OSP12 RFE bug.

*** This bug has been marked as a duplicate of bug 1259035 ***


Note You need to log in before you can comment on or make changes to this bug.