Bug 1410864 - python-celery is broken in rawhide
Summary: python-celery is broken in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-celery
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1400270 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 16:14 UTC by Jeremy Cline
Modified: 2017-01-11 09:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 09:02:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeremy Cline 2017-01-06 16:14:47 UTC
Description of problem: Since kombu has been updated, celery is broken in rawhide as the old version of celery is importing things that no longer exist in kombu


Version-Release number of selected component (if applicable): python2-celery-3.1.20-5.fc26.noarch


How reproducible: always


Steps to Reproduce:
1. Start a python shell
2. >>> from celery import five
3.

Actual results:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/celery/__init__.py", line 133, in <module>
    from celery import five  # noqa
  File "/usr/lib/python2.7/site-packages/celery/five.py", line 153, in <module>
    from kombu.utils.compat import OrderedDict  # noqa
ImportError: cannot import name OrderedDict


The latest version of celery is 4.0.2.

Comment 1 Matthias Runge 2017-01-09 20:12:04 UTC
five became an own package in rawhide. Will upgrade asap

Comment 2 Zbigniew Jędrzejewski-Szmek 2017-01-11 04:24:40 UTC
*** Bug 1400270 has been marked as a duplicate of this bug. ***

Comment 3 Zbigniew Jędrzejewski-Szmek 2017-01-11 04:25:53 UTC
This is also blocking the rebuild of python-flower for python3.6.


Note You need to log in before you can comment on or make changes to this bug.