Bug 1411366 - introspection and boot initramfs images don't include iscsi drivers
Summary: introspection and boot initramfs images don't include iscsi drivers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-image-elements
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Yolanda Robla
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1276147 1283436 1467377
TreeView+ depends on / blocked
 
Reported: 2017-01-09 14:52 UTC by Yuval Adar
Modified: 2018-02-06 20:10 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-image-elements-6.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1467377 (view as bug list)
Environment:
Last Closed: 2017-05-17 19:55:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 420765 None None None 2017-03-24 15:56:52 UTC

Description Yuval Adar 2017-01-09 14:52:35 UTC
Description of problem:
be2iscsi driver is not included in introspection and boot initramfs images for overcloud

Version-Release number of selected component (if applicable):


How reproducible:
Introspection fails on diskless nodes with iscsi attached root disk when using default introspection image


Additional info:
Issue was solved by rebuilding the introspection and boot images using DIB.
drivers atted to images:
be2iscsi
dm_multipath
iscsi_target_mod

rpm's added to overcloud image:
iscsi-initiator-utils
openstack-ironic-python-agent

Patch added to ironic_python_agent:

--- /lib/python2.7/site-packages/ironic_python_agent/hardware.py        2016-07-18 22:02:53.668820422 -0400
+++ /lib/python2.7/site-packages/ironic_python_agent/hardware.py        2016-07-18 14:40:33.578307259 -0400
@@ -52,6 +52,27 @@
     except IOError:
         LOG.warning("Can't find the device vendor for device %s", dev)

+def _check_for_iscsi():
+    """iscsi detection
+    iscsistart -f will print the iBFT or OF info.
+    In case such connection exists, we would like to issue
+    iscsistart -b to create a session to the target.
+    - if no connection is detected we simply return.
+    """
+    if os.path.exists('/var/run/iscsistart.pid'):
+        return
+    else :
+        utils.execute('/bin/touch','/var/run/iscsistart.pid')
+    try:
+        utils.execute('iscsistart', '-f')
+    except processutils.ProcessExecutionError as e:
+        LOG.info('No iscsi connection detected. Skipping iscsi.')
+        return
+    try:
+        utils.execute('iscsistart', '-b')
+    except processutils.ProcessExecutionError as e:
+        LOG.warning('Something went wrong executing iscsistart -b'
+                    'Error: %s', e)

 def _udev_settle():
     """Wait for the udev event queue to settle.
@@ -383,6 +404,7 @@

     def evaluate_hardware_support(self):
         # Do some initialization before we declare ourself ready
+        _check_for_iscsi()
         self._wait_for_disks()
         return HardwareSupport.GENERIC

Comment 1 Yolanda Robla 2017-01-11 12:03:06 UTC
Just wanted to note that check_for_iscsi code is already present on newton, so this customization is only needed for OSP8.

Comment 2 Yolanda Robla 2017-01-12 12:12:23 UTC
I created bug https://bugs.launchpad.net/tripleo/+bug/1655681 to reflect the need for ramdisk update, either in deployment image and later on the initramfs

Comment 3 Yolanda Robla 2017-01-12 14:59:49 UTC
https://review.openstack.org/#/c/419486

Comment 4 Yolanda Robla 2017-01-16 10:50:07 UTC
Also need to clarify that this is needed on the ironic-python-image, not in overcloud-full

Comment 5 Yolanda Robla 2017-01-17 16:36:36 UTC
I need feedback on https://review.openstack.org/420765 , that is adding an element to update dracut in the agent and enable drivers

Comment 6 Yolanda Robla 2017-01-18 11:03:55 UTC
Review of the patch was done by Yuval

Comment 7 Yolanda Robla 2017-02-02 10:14:58 UTC
Patch landed

Comment 9 Yolanda Robla 2017-03-27 15:34:24 UTC
The latest puddle includes that patch.

Comment 11 errata-xmlrpc 2017-05-17 19:55:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.