Bug 1411527 - Unable to provision VMs to a VLAN with a '/' in the name
Summary: Unable to provision VMs to a VLAN with a '/' in the name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: Adam Grare
QA Contact: Alex Newman
URL:
Whiteboard: vm:provision
: 1426337 (view as bug list)
Depends On:
Blocks: 1420442 1420466
TreeView+ depends on / blocked
 
Reported: 2017-01-09 22:13 UTC by Saif Ali
Modified: 2020-05-14 15:31 UTC (History)
16 users (show)

Fixed In Version: 5.8.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1420442 1420466 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:29:36 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Logs (9.65 MB, application/x-xz)
2017-01-09 22:13 UTC, Saif Ali
no flags Details

Description Saif Ali 2017-01-09 22:13:00 UTC
Created attachment 1238916 [details]
Logs

Description of problem:
vlan_123_audit
vlan_456_prod_middletier_172.16.33/24

When attempting to provision to a VLAN with a '/' in the name, the automation method prov.set_customization_spec(spec, true) sets the prov.options[:vlan] to [nil, nil]. This results in the provision failing to be placed because it can not find a host with the VLAN 'nil'.

Version-Release number of selected component (if applicable):
5.6.2.2-20161017185613_7cee0a0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 7 Greg McCullough 2017-01-19 14:21:46 UTC
Based on the previous logic here we likely want to encode the value before doing the db lookup:
https://github.com/ManageIQ/manageiq/blob/capablanca/app/models/manageiq/providers/vmware/infra_manager/provision/configuration/network.rb#L84

Comment 14 Greg McCullough 2017-02-23 18:58:13 UTC
*** Bug 1426337 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.