Bug 1411596 - Virtio driver of network device works abnormally when convert win2008 x86 guest from kvm to rhev by virt-v2v
Summary: Virtio driver of network device works abnormally when convert win2008 x86 gue...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1372174
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 03:45 UTC by mxie@redhat.com
Modified: 2017-08-01 12:55 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:55:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot1 (78.10 KB, image/png)
2017-01-10 03:45 UTC, mxie@redhat.com
no flags Details
screenshot2 (87.43 KB, image/png)
2017-01-10 03:47 UTC, mxie@redhat.com
no flags Details
v2v-7.3.z-virtio-1.9.0-3.log (371.10 KB, text/plain)
2017-01-10 03:48 UTC, mxie@redhat.com
no flags Details
v2v-7.3.z-virtio-1.8.0-4.log (370.93 KB, text/plain)
2017-01-10 03:48 UTC, mxie@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2341 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2017-08-01 16:52:38 UTC

Description mxie@redhat.com 2017-01-10 03:45:43 UTC
Created attachment 1238972 [details]
screenshot1

Description of problem:
Virtio driver of network device works abnormally when convert win2008 x86 guest from kvm to rhev by virt-v2v

Version-Release number of selected component (if applicable):
virt-v2v-1.32.7-3.el7_3.2.x86_64
libguestfs-1.32.7-3.el7_3.2.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
libvirt-2.0.0-10.el7_3.4.x86_64
virtio-win-1.9.0-3.el7.noarch
libguestfs-winsupport-7.2-1.el7.x86_64
RHVM:4.0.6.3-0.1.el7ev


How reproducible:
100%

Steps to Reproduce:
1.Convert win2008 x86 guest from kvm to rhev by virt-v2v
# virt-v2v kvm-win2008-i386-qcow2 -n ovirtmgmt -b ovirtmgmt -o rhev -os 10.73.131.93:/home/iso_domain
[   0.0] Opening the source -i libvirt kvm-win2008-i386-qcow2
[   0.0] Creating an overlay to protect the source from being modified
[   0.9] Initializing the target -o rhev -os 10.73.131.93:/home/iso_domain
[   3.6] Opening the overlay
[   5.5] Inspecting the overlay
[   5.9] Checking for sufficient free disk space in the guest
[   5.9] Estimating space required on target for each disk
[   5.9] Converting Windows Server (R) 2008 Enterprise to run on KVM
virt-v2v: warning: there is no QXL driver for this version of Windows (6.0 
i386).  virt-v2v looks for this driver in /usr/share/virtio-win

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[   6.2] Mapping filesystem data to avoid copying unused and blank areas
[   7.1] Closing the overlay
[   7.1] Checking if the guest needs BIOS or UEFI to boot
[   7.1] Assigning disks to buses
[   7.1] Copying disk 1/1 to /tmp/v2v.Z8E0g2/4e4bd840-2178-4b5a-b3d2-80f612d7a7e4/images/8735d2ad-d361-437e-94ff-33911d9de8b5/fde27c61-3aa1-4811-9e70-71da9c40096e (qcow2)
    (100.00/100%)
[  81.6] Creating output metadata
[  81.6] Finishing off


2.Import the guest from export domain to data domain after finishing v2v conversion

3.Power on the guest after finishing importing

4.Open the console of guest and virtio drivers will be installed automativately, you can see that the network device has installed virtio driver successfully as screenshot1,  restart the guest according to the reminder of windows system

5.Log into the guest and checkpoints, but found that virtio driver of network device has yellow bang and there is no network available in guest, driver status of network device shows "device can't start", pls refer to sreenshot2 and v2v-7.3.z-virtio-1.9.0-3.log

6.Yum downgrade virtio-win to 1.8.0-4.el7.noarch, then repeat step1 ~ step5,virtio driver of network device works normally after converting win2008 x86 guest from kvm to rhev by virt-v2v, so this is a regresstio bug on virtio-win, pls refer to log "v2v-7.3.z-virtio-1.8.0-4.log "


Actual results:
As above description 

Expected results:
Virtio driver of network device works normally when convert win2008 x86 guest from kvm to rhev by virt-v2v

Additional info:
1.Virtio driver of network device works normally when convert win2008 x64 guest from kvm to rhev by virt-v2v
2.Virtio driver of network device works normally when convert win2008 x86 guest from vmware to rhev by virt-v2v
3.It is strange that converting win2008 x86 guest from kvm to rhev by virt-v2v auto runing could be passed sometimes , pls refer to details log:https://libvirt-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/v2v/view/RHEL-7.3/job/v2v-RHEL-7.3-runtest-x86_64-matrix-kvm/3/testReport/rhev/convert_vm_to_ovirt/kvm_windows_win2008_i386_raw_f_NFS/

Comment 1 mxie@redhat.com 2017-01-10 03:47:16 UTC
Created attachment 1238974 [details]
screenshot2

Comment 2 mxie@redhat.com 2017-01-10 03:48:09 UTC
Created attachment 1238975 [details]
v2v-7.3.z-virtio-1.9.0-3.log

Comment 3 mxie@redhat.com 2017-01-10 03:48:45 UTC
Created attachment 1238976 [details]
v2v-7.3.z-virtio-1.8.0-4.log

Comment 17 lijin 2017-03-29 03:18:43 UTC
change status to verified according to comment#12

Comment 20 errata-xmlrpc 2017-08-01 12:55:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341


Note You need to log in before you can comment on or make changes to this bug.