Bug 1411598 - Remove own-thread option entirely for SSL and use epoll event infrastructure
Summary: Remove own-thread option entirely for SSL and use epoll event infrastructure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1411597
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 03:50 UTC by Mohit Agrawal
Modified: 2019-05-11 11:38 UTC (History)
4 users (show)

Fixed In Version: glusterfs-6.x
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1411597
Environment:
Last Closed: 2019-05-11 11:38:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-10 08:24:10 UTC
REVIEW: http://review.gluster.org/16368 ([WIP] socket: remove own_thread specific code while using SSL) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 2 Worker Ant 2017-01-10 08:52:00 UTC
REVIEW: http://review.gluster.org/16368 ([WIP] socket: remove own_thread specific code while using SSL) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 3 Mohit Agrawal 2017-05-22 08:28:20 UTC
The patch needs to be revisit ,currently busy in other bugzilla's so will check it
later.

Comment 4 Amar Tumballi 2018-10-08 17:40:51 UTC
patch not merged yet!

Comment 5 Mohit Agrawal 2018-11-19 04:08:49 UTC
The issue is already fixed by the bugzilla
https://bugzilla.redhat.com/show_bug.cgi?id=1561332
and Patch is already merged in upstream
https://review.gluster.org/#/c/glusterfs/+/19308/


Thanks,
Mohit Agrawal

Comment 6 Yaniv Kaul 2019-04-24 09:16:49 UTC
So what's the next step here?


Note You need to log in before you can comment on or make changes to this bug.