Bug 1411612 - Fix the place where graph switch event is logged
Summary: Fix the place where graph switch event is logged
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1411613 1411614
TreeView+ depends on / blocked
 
Reported: 2017-01-10 06:20 UTC by Krutika Dhananjay
Modified: 2017-03-08 10:24 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1411613 1411614 (view as bug list)
Environment:
Last Closed: 2017-03-08 10:24:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2017-01-10 06:20:24 UTC
Description of problem:
This should give more precise timestamp that indicates *exactly* when graph switch took place and hopefully help with some of the graph-switch related bugs that the users are reporting in future.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-01-10 06:23:18 UTC
REVIEW: http://review.gluster.org/16365 (mount/fuse: Fix the place where graph-switch event is logged) posted (#1) for review on release-3.9 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2017-01-13 09:29:20 UTC
COMMIT: http://review.gluster.org/16365 committed in release-3.9 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit aecd5234bdabec11588da352dbfea7268e6127fc
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Dec 28 14:32:12 2016 +0530

    mount/fuse: Fix the place where graph-switch event is logged
    
            Backport of: http://review.gluster.org/16302
    
    Change-Id: I3c8577b87db02a2a6ce6159e7d04cf58a2bda0c1
    BUG: 1411612
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/16365
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2017-03-08 10:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.1, please open a new bug report.

glusterfs-3.9.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-January/029725.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.