Bug 1411614 - Fix the place where graph switch event is logged
Summary: Fix the place where graph switch event is logged
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: 3.7.18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On: 1411612
Blocks: 1411613
TreeView+ depends on / blocked
 
Reported: 2017-01-10 06:28 UTC by Krutika Dhananjay
Modified: 2017-02-01 11:38 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.20
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1411612
Environment:
Last Closed: 2017-02-01 11:38:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2017-01-10 06:28:34 UTC
+++ This bug was initially created as a clone of Bug #1411612 +++

Description of problem:
This should give more precise timestamp that indicates *exactly* when graph switch took place and hopefully help with some of the graph-switch related bugs that the users are reporting in future.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-01-10 01:23:18 EST ---

REVIEW: http://review.gluster.org/16365 (mount/fuse: Fix the place where graph-switch event is logged) posted (#1) for review on release-3.9 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 1 Worker Ant 2017-01-10 06:29:39 UTC
REVIEW: http://review.gluster.org/16367 (mount/fuse: Fix the place where graph-switch event is logged) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2017-01-11 04:14:49 UTC
REVIEW: http://review.gluster.org/16367 (mount/fuse: Fix the place where graph switch event is logged) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Worker Ant 2017-01-13 09:29:29 UTC
COMMIT: http://review.gluster.org/16367 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b2ead317933a48ce00f3ee1460080cf4ad16ec9b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Dec 28 14:32:12 2016 +0530

    mount/fuse: Fix the place where graph switch event is logged
    
            Backport of: http://review.gluster.org/16302
    
    Change-Id: I3c8577b87db02a2a6ce6159e7d04cf58a2bda0c1
    BUG: 1411614
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/16367
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Kaushal 2017-02-01 11:38:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.20, please open a new bug report.

glusterfs-3.7.20 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/gluster-devel/2017-January/052010.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.