Bug 1411640 - [HC] - Include gdeploy package in oVirt Node
Summary: [HC] - Include gdeploy package in oVirt Node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.1.1
: 4.1
Assignee: Ryan Barry
QA Contact: Yihui Zhao
URL:
Whiteboard:
: 1420545 (view as bug list)
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-01-10 08:20 UTC by Ramesh N
Modified: 2017-04-21 09:39 UTC (History)
19 users (show)

Fixed In Version: redhat-release-virtualization-host-4.1-0.3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:39:37 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
sbonazzo: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)
New Src rpm (1.86 MB, application/x-rpm)
2017-01-27 09:18 UTC, Ramesh N
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 71394 master MERGED Add gdeploy to node 2017-01-31 10:22:06 UTC
oVirt gerrit 71442 ovirt-hosted-engine-setup-2.1 MERGED packaging: remove checks on gluster version for HC 2017-02-01 15:13:49 UTC
oVirt gerrit 71527 ovirt-hosted-engine-setup-2.1 MERGED packaging: remove checks on gluster version for HC 2017-02-01 16:58:42 UTC
oVirt gerrit 71632 ovirt-4.1 MERGED Add gdeploy to node 2017-02-07 10:41:10 UTC

Description Ramesh N 2017-01-10 08:20:15 UTC
Description of problem:

We need gdeploy package to support Hyperconverged deployments. We have added a plugin in cockpit-ovirt-dashboard to support this deployment. But gdeploy is not yet included in the Node. We need gdeploy package for this plugin to work. Can we include gdeploy package in the Node iso?.


Additional info:
   Gdeploy package is not yet available in upstream EPEL, CentosSIG/Fedora repos. But we have builds available in gluter.org website.

https://download.gluster.org/pub/gluster/gdeploy/LATEST/

Comment 1 Sandro Bonazzola 2017-01-10 08:34:42 UTC
Ramesh, the request here is just to include the package, correct?
Gluster team will hanlde the support for this package right?

Comment 2 Ramesh N 2017-01-10 08:39:50 UTC
(In reply to Sandro Bonazzola from comment #1)
> Ramesh, the request here is just to include the package, correct?
> Gluster team will hanlde the support for this package right?

yes. It will be supported and maintained by gluster team.

Comment 3 Sandro Bonazzola 2017-01-10 09:07:29 UTC
Ryan, we need to understand if we can just add the package to the channel or we need to include it in the image. Is it possible to get the package installed when the cockpit ui is used?

Comment 5 Ryan Barry 2017-01-10 19:49:28 UTC
We're better off including this in oVirt Node out of the box. We can theoretically enable some other repo, but this comes with a potential laundry list of problems as the dependencies get updated.

Comment 6 Sandro Bonazzola 2017-01-21 04:58:56 UTC
(In reply to Ramesh N from comment #0)
>    Gdeploy package is not yet available in upstream EPEL, CentosSIG/Fedora
> repos. But we have builds available in gluter.org website.
> 
> https://download.gluster.org/pub/gluster/gdeploy/LATEST/

We can't import these builds on hosts since the URL is not a valid yum repository. Also that URL is missing src.rpm .

We need to rebuild it in copr and add the copr repository to ovirt-release dependenies.
Ramesh, can you do that?

Comment 7 Sandro Bonazzola 2017-01-23 17:32:03 UTC
Ramesh, please verify both fc24 and el7 packages from https://copr.fedorainfracloud.org/coprs/sbonazzo/gdeploy/build/502960/
If they're ok I'll add them to the repo.

Comment 8 Ramesh N 2017-01-25 09:31:57 UTC
(In reply to Sandro Bonazzola from comment #7)
> Ramesh, please verify both fc24 and el7 packages from
> https://copr.fedorainfracloud.org/coprs/sbonazzo/gdeploy/build/502960/
> If they're ok I'll add them to the repo.

Thank you for packing gdeploy. It is failing to install because of following dependency issues. Can we include these pacakges from EPEL?. Also in long run, how update the packages in your repo?. Can gdeploy maintainer (sac) update them as and when require?


Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
           Requires: python-jinja2 >= 2.7.3
           Installing: python-jinja2-2.7.2-2.el7.noarch (base)
               python-jinja2 = 2.7.2-2.el7
Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
           Requires: python-jinja2 >= 2.7.3
           Available: python-jinja2-2.7.2-2.el7.noarch (base)
               python-jinja2 = 2.7.2-2.el7
Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
           Requires: python-markupsafe >= 0.23
           Available: python-markupsafe-0.11-10.el7.x86_64 (base)
               python-markupsafe = 0.11-10.el7
Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
           Requires: PyYAML >= 3.11
           Installed: PyYAML-3.10-11.el7.x86_64 (@base)
               PyYAML = 3.10-11.el7
Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
           Requires: python-markupsafe >= 0.23
           Installing: python-markupsafe-0.11-10.el7.x86_64 (base)
               python-markupsafe = 0.11-10.el7

Comment 9 Sandro Bonazzola 2017-01-26 15:01:01 UTC
(In reply to Ramesh N from comment #8)
> Thank you for packing gdeploy. It is failing to install because of following
> dependency issues. Can we include these pacakges from EPEL?. Also in long
> run, how update the packages in your repo?. Can gdeploy maintainer (sac)
> update them as and when require?

I need to check but I think I can give permission to another copr user to work on the same copr project. Just let me know the copr user details to be authorized.

I would really prefer to see gdeploy in fedora repo and in CentOS Storage SIG repositories.
Niels, can you help with this?

About the missing deps:
> Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
>            Requires: python-jinja2 >= 2.7.3
>            Installing: python-jinja2-2.7.2-2.el7.noarch (base)
>                python-jinja2 = 2.7.2-2.el7
> Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
>            Requires: python-jinja2 >= 2.7.3
>            Available: python-jinja2-2.7.2-2.el7.noarch (base)
>                python-jinja2 = 2.7.2-2.el7
> Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
>            Requires: python-markupsafe >= 0.23
>            Available: python-markupsafe-0.11-10.el7.x86_64 (base)
>                python-markupsafe = 0.11-10.el7
> Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
>            Requires: PyYAML >= 3.11
>            Installed: PyYAML-3.10-11.el7.x86_64 (@base)
>                PyYAML = 3.10-11.el7
> Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
>            Requires: python-markupsafe >= 0.23
>            Installing: python-markupsafe-0.11-10.el7.x86_64 (base)
>                python-markupsafe = 0.11-10.el7

Please open a bug on ovirt-release product to add them to the epel repository inclusion.

Comment 10 Niels de Vos 2017-01-26 17:06:15 UTC
I would like to include gdeploy in the CentOS Storage SIG as well. Unfortunately there has been a blocker to get the Ansible dependencies included. I've posted https://lists.centos.org/pipermail/centos-devel/2017-January/015633.html to get some more details. The goal is to have all Ansible dependencies in a repository provided by the CfgMgmt SIG, but it seems there has been little progress since last November.

Until there is a CentOS SIG that provides the Ansible packages and dependencies, gdeploy can not be included in the Storage SIG.

Comment 11 Ramesh N 2017-01-27 05:29:08 UTC
(In reply to Sandro Bonazzola from comment #9)
> (In reply to Ramesh N from comment #8)
> > Thank you for packing gdeploy. It is failing to install because of following
> > dependency issues. Can we include these pacakges from EPEL?. Also in long
> > run, how update the packages in your repo?. Can gdeploy maintainer (sac)
> > update them as and when require?
> 
> I need to check but I think I can give permission to another copr user to
> work on the same copr project. Just let me know the copr user details to be
> authorized.
> 
> I would really prefer to see gdeploy in fedora repo and in CentOS Storage
> SIG repositories.
> Niels, can you help with this?
> 
> About the missing deps:
> > Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
> >            Requires: python-jinja2 >= 2.7.3
> >            Installing: python-jinja2-2.7.2-2.el7.noarch (base)
> >                python-jinja2 = 2.7.2-2.el7
> > Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
> >            Requires: python-jinja2 >= 2.7.3
> >            Available: python-jinja2-2.7.2-2.el7.noarch (base)
> >                python-jinja2 = 2.7.2-2.el7
> > Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
> >            Requires: python-markupsafe >= 0.23
> >            Available: python-markupsafe-0.11-10.el7.x86_64 (base)
> >                python-markupsafe = 0.11-10.el7
> > Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
> >            Requires: PyYAML >= 3.11
> >            Installed: PyYAML-3.10-11.el7.x86_64 (@base)
> >                PyYAML = 3.10-11.el7
> > Error: Package: gdeploy-2.0.1-1.el7.centos.noarch (sbonazzo-gdeploy)
> >            Requires: python-markupsafe >= 0.23
> >            Installing: python-markupsafe-0.11-10.el7.x86_64 (base)
> >                python-markupsafe = 0.11-10.el7
> 
> Please open a bug on ovirt-release product to add them to the epel
> repository inclusion.

Looks like specific version of these dependencies are not yet available in EPEL. I am not sure why gdeploy has these direct dependencies when ansible itself has these dependencies. I have raised a bug in gdeploy to correct this.

Comment 12 Ramesh N 2017-01-27 09:18:44 UTC
Created attachment 1245069 [details]
New Src rpm

Comment 13 Ramesh N 2017-01-27 09:40:46 UTC
Sandro, I have attached the new src rpm with the fixes. This removes all the direct dependencies on python-markupsafe,  PyYAML and python-jinja2. We just need ansible >= 2.2. Does oVirt already ships ansible from EPEL?

Comment 14 Ramesh N 2017-01-30 13:21:38 UTC
I have rebuilt the gdeploy packages in copr repo. Please use the copr repos from
https://copr.fedorainfracloud.org/coprs/rnachimu/gdeploy/ to get the latest gdeploy package.

Comment 15 Ryan Barry 2017-02-08 23:20:07 UTC
*** Bug 1420545 has been marked as a duplicate of this bug. ***

Comment 16 Moacir 2017-02-09 00:01:26 UTC
Ramesh, on a fresh install (ovirt-node-ng-installer-ovirt-4.1-2017020112.iso) where I added your repository I get the following error messages when I try to install gdeploy:
Error: Package: gdeploy-2.0.1-11.noarch (rnachimu-gdeploy)
           Requires: python-markupsafe
Error: Package: gdeploy-2.0.1-11.noarch (rnachimu-gdeploy)
           Requires: ansible >= 2.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 18 Yihui Zhao 2017-02-10 05:54:57 UTC
The gdeploy package is include in RHVH4.1(rhvh-4.1-0.20170208.0+1)

Version if available:
rhvh-4.1-0.20170208.0+1
gdeploy-2.0.1-8.el7rhgs.noarch


[root@dhcp-10-229 ~]# imgbase w
[INFO] You are on rhvh-4.1-0.20170208.0+1
[root@dhcp-10-229 ~]# rpm -qa |grep gdeploy
gdeploy-2.0.1-8.el7rhgs.noarch


 So I will verify this bug after bug change to ON_QA status.

Comment 19 Yihui Zhao 2017-02-20 14:23:47 UTC
According to Comment18, the bug's status is verified.


Note You need to log in before you can comment on or make changes to this bug.