Bug 1411649 - HPE [RFE] [RHOSP Director] Production support for VM high availability
Summary: HPE [RFE] [RHOSP Director] Production support for VM high availability
Keywords:
Status: CLOSED DUPLICATE of bug 1264181
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Eoghan Glynn
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks: 1389435 1402132
TreeView+ depends on / blocked
 
Reported: 2017-01-10 08:33 UTC by hrushi
Modified: 2019-09-09 14:18 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 19:57:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description hrushi 2017-01-10 08:33:50 UTC
Most of the RFPs we get from VNF vendors and communication providers is to provide high-availability for VM instances in the following faulty conditions:
1. VM failure, 
2. vSwitch failure
3. Connectivity failure
4. Compute node failure

RH has documented procedure but is not OSPd aware hence not supported in production. This feature request track implementation of VM high availability through OSPd. 
https://access.redhat.com/solutions/2661641
https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/single/high-availability-for-compute-instances/
 
“While implementing High Availability for Instances, no upgrade or scale-up operations are possible. Any attempts to do so will fail.
In addition, enabling High Availability for Instances will prevent you from using the director to upgrade the overcloud in the future. This applies to both major and minor upgrades. 
 
As upgrade is must for any production types deployment, we need this implementation through OSPd.

Comment 1 Stephen Gordon 2017-01-18 19:57:56 UTC

*** This bug has been marked as a duplicate of bug 1264181 ***


Note You need to log in before you can comment on or make changes to this bug.