Bug 141166 - HAL doesn't startup
HAL doesn't startup
Status: CLOSED DUPLICATE of bug 140081
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 13:42 EST by Joshua Ginsberg
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Ginsberg 2004-11-29 13:42:44 EST
When running "service haldaemon start", everything reports fine, but
hald is not listed in my running processes.

When running "hald --daemon=yes --verbose=yes", stdout reports:

11:42:49.501 [I] hald.c:394: hal 0.4.0
11:42:49.501 [I] hald.c:396: Will daemonize
11:42:49.502 [I] hald.c:406: Becoming a daemon

but again, hald is not listed in my running processes.

When running "hald --daemon=no --verbose=yes", stdout/err reports:

11:43:27.804 [I] hald.c:394: hal 0.4.0
11:43:27.805 [I] hald.c:398: Will not daemonize
Segmentation fault


When running "strace hald --daemon=no", stdout/err reports:

execve("/usr/sbin/hald", ["hald", "--daemon=no"], [/* 21 vars */]) = 0
uname({sys="Linux", node="localhost.localdomain", ...}) = 0
brk(0)                                  = 0xa060000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or
directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=74363, ...}) = 0
old_mmap(NULL, 74363, PROT_READ, MAP_PRIVATE, 3, 0) = 0xf6fed000
close(3)                                = 0
open("/usr/lib/libgobject-2.0.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 \nX\000"...,
512) = 512fstat64(3, {st_mode=S_IFREG|0755, st_size=239912, ...}) = 0
old_mmap(0x57a000, 242816, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x57a000
old_mmap(0x5b4000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x39000) = 0x5b4000
old_mmap(0x5b5000, 1152, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x5b5000
close(3)                                = 0
open("/usr/lib/libdbus-glib-1.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360Q\267"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=45284, ...}) = 0
old_mmap(0xb71000, 46728, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb71000
old_mmap(0xb7c000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xa000) = 0xb7c000
close(3)                                = 0
open("/usr/lib/libglib-2.0.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000\227"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=505200, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xf6fec000
old_mmap(0x4fd000, 503692, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x4fd000
old_mmap(0x577000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x7a000) = 0x577000
close(3)                                = 0
open("/usr/lib/libdbus-1.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340\347"...,
512) = 512fstat64(3, {st_mode=S_IFREG|0755, st_size=377448, ...}) = 0
old_mmap(0x7899000, 375152, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7899000
old_mmap(0x78f4000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x5b000) = 0x78f4000
close(3)                                = 0
open("/lib/tls/libm.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0c=\000"...,
512) = 512fstat64(3, {st_mode=S_IFREG|0755, st_size=215248, ...}) = 0
old_mmap(0x3d3000, 139424, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x3d3000
old_mmap(0x3f4000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x20000) = 0x3f4000
close(3)                                = 0
open("/lib/libcap.so.1", O_RDONLY)      = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\350\212"...,
512) = 512fstat64(3, {st_mode=S_IFREG|0755, st_size=11788, ...}) = 0
old_mmap(0x3f8000, 13972, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x3f8000
old_mmap(0x3fb000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x2000) = 0x3fb000
close(3)                                = 0
open("/usr/lib/libexpat.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\320\277"...,
512) = 512fstat64(3, {st_mode=S_IFREG|0755, st_size=127592, ...}) = 0
old_mmap(0x64a000, 124868, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x64a000
old_mmap(0x667000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1d000) = 0x667000
close(3)                                = 0
open("/lib/libselinux.so.1", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\2400\266"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=56320, ...}) = 0
old_mmap(0xb61000, 56172, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb61000
old_mmap(0xb6e000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xd000) = 0xb6e000
close(3)                                = 0
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0
\357+\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1512400, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xf6feb000
old_mmap(0x2aa000, 1207532, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x2aa000
old_mmap(0x3cb000, 16384, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x120000) = 0x3cb000
old_mmap(0x3cf000, 7404, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x3cf000
close(3)                                = 0
open("/lib/libnsl.so.1", O_RDONLY)      = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p\312\264"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=96020, ...}) = 0
old_mmap(0xb49000, 88288, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb49000
old_mmap(0xb5b000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x11000) = 0xb5b000
old_mmap(0xb5d000, 6368, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb5d000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xf6fea000
mprotect(0x3f4000, 4096, PROT_READ)     = 0
mprotect(0x3cb000, 8192, PROT_READ)     = 0
mprotect(0xb5b000, 4096, PROT_READ)     = 0
mprotect(0x2a6000, 4096, PROT_READ)     = 0
set_thread_area({entry_number:-1 -> 6, base_addr:0xf6fea6c0,
limit:1048575, seg_32bit:1, contents:0, read_exec_only:0,
limit_in_pages:1, seg_not_present:0, useable:1}) = 0
munmap(0xf6fed000, 74363)               = 0
access("/etc/selinux/", F_OK)           = 0
brk(0)                                  = 0xa060000
brk(0xa081000)                          = 0xa081000
open("/etc/selinux/config", O_RDONLY)   = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=448, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xf6fff000
read(3, "# This file controls the state o"..., 4096) = 448
close(3)                                = 0
munmap(0xf6fff000, 4096)                = 0
open("/proc/mounts", O_RDONLY)          = 3
fstat64(3, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xf6fff000
read(3, "rootfs / rootfs rw 0 0\n/proc /pr"..., 1024) = 558
close(3)                                = 0
munmap(0xf6fff000, 4096)                = 0
pipe([3, 4])                            = 0
fstat64(3, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
fcntl64(3, F_GETFL)                     = 0 (flags O_RDONLY)
rt_sigaction(SIGTERM, {0x8051927, [TERM], SA_RESTORER|SA_RESTART,
0x2d1a48}, {SIG_DFL}, 8) = 0
open("/etc/hal/hald.conf", O_RDONLY|O_LARGEFILE) = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=1582, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xf6fff000
fstat64(5, {st_mode=S_IFREG|0644, st_size=1582, ...}) = 0
_llseek(5, 0, [0], SEEK_SET)            = 0
read(5, "<?xml version=\"1.0\" encoding=\"IS"..., 1582) = 1582
_llseek(5, 1582, [1582], SEEK_SET)      = 0
close(5)                                = 0
munmap(0xf6fff000, 4096)                = 0
socket(PF_FILE, SOCK_STREAM, 0)         = 5
connect(5, {sa_family=AF_FILE,
path="/var/run/dbus/system_bus_socket"}, 110) = 0fcntl64(5, F_GETFL) 
                   = 0x2 (flags O_RDWR)
fcntl64(5, F_SETFL, O_RDWR|O_NONBLOCK)  = 0
fcntl64(5, F_GETFD)                     = 0
fcntl64(5, F_SETFD, FD_CLOEXEC)         = 0
getuid32()                              = 0
rt_sigaction(SIGPIPE, {SIG_IGN}, {SIG_DFL}, 8) = 0
poll([{fd=5, events=POLLOUT, revents=POLLOUT}], 1, -1) = 1
write(5, "\0", 1)                       = 1
write(5, "AUTH EXTERNAL 30\r\n", 18)    = 18
poll([{fd=5, events=POLLIN, revents=POLLIN}], 1, -1) = 1
read(5, "OK\r\n", 2048)                 = 4
poll([{fd=5, events=POLLOUT, revents=POLLOUT}], 1, -1) = 1
write(5, "BEGIN\r\n", 7)                = 7
writev(5,
[{"l\1\0\0\200\0\0\0\0\0\0\0\1\0\0\0\1o\0\0\25\0\0\0/org/"..., 128},
{"", 0}], 2) = 128
gettimeofday({1101753838, 770018}, NULL) = 0
poll([{fd=5, events=POLLIN, revents=POLLIN}], 1, 15000) = 1
read(5, "l\2\1\0P\0\0\0\16\0\0\0\1\0\0\0\5u\0\0\1\0\0\0\10s\0\0"...,
2048) = 260read(5, 0xa067bb0, 2048)                = -1 EAGAIN
(Resource temporarily unavailable)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

As a result, eggcups and gnome-volume-manager fail at login, and
Nautilus simply hangs.

-jag
Comment 1 David Zeuthen 2004-11-29 13:53:11 EST
This looks like a dupe of 140081 - please try the new prelink package
in updates/testing to see if this goes away.

*** This bug has been marked as a duplicate of 140081 ***
Comment 2 Joshua Ginsberg 2004-11-29 14:22:07 EST
You are correct. It is a dupe. Thanks!
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.