Bug 141174 - Anaconda exception during FC2 -> FC3 upgrade after choosing the FC installation to upgrade
Anaconda exception during FC2 -> FC3 upgrade after choosing the FC installati...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
: 141879 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 14:10 EST by Karen Heiby
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:13:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The core dump I saved to the floppy when prompted (54.65 KB, text/plain)
2004-11-29 14:11 EST, Karen Heiby
no flags Details
the /etc/fstab in question (1.30 KB, text/plain)
2004-12-01 11:02 EST, Karen Heiby
no flags Details

  None (edit)
Description Karen Heiby 2004-11-29 14:10:17 EST
Description of problem:
When trying to upgrade from FC2, anaconda core dumps after it detects
my previous installation and I choose it for upgrading.

How reproducible:
Always, at least on this machine.


Steps to Reproduce:
1.  Boot up, insert installation DVD, pick either the graphical or the
text install mode (doesn't matter)
2.  Choose to upgrade an existing version of Fedora, in this case, FC2
3.  Witness Anaconda error and the prompt to save the core dump to a
floppy.
  
Actual results:  Can't get past this, and can't upgrade to FC3


Expected results:  Successful upgrade


Additional info:  Will attach the .txt file saved to my floppy
Comment 1 Karen Heiby 2004-11-29 14:11:53 EST
Created attachment 107564 [details]
The core dump I saved to the floppy when prompted

Here's the output of the core dump.
Comment 2 Paul Nasrat 2004-12-01 10:28:55 EST
Can you attach your fc2 /etc/fstab - we don't seem to have a / entry
in our fs list.
Comment 3 Karen Heiby 2004-12-01 11:02:54 EST
Created attachment 107720 [details]
the /etc/fstab in question
Comment 4 Karen Heiby 2004-12-01 11:03:38 EST
<Can you attach your fc2 /etc/fstab - we don't seem to have a / entry
in our fs list.>

Yes, I noticed a curiosity in fstab yesterday.  Somehow, cLABEL keeps
sneaking in there when it should be LABEL.  I've seen this before and
don't know what is doing this.  Perhaps changing this back to LABEL
will work.  (Above is attachment of fstab).  Thanks.
Comment 5 Paul Nasrat 2004-12-01 11:11:24 EST
Yes changing back to LABEL should make it work. Can you edit, confirm
correct with head /etc/fstab then retry the upgrade?
Comment 6 Paul Nasrat 2004-12-01 12:23:43 EST
I've also commited a fix to HEAD to not trace back and give an error
message in the case of no / in fstab
Comment 7 Karen Heiby 2004-12-03 03:56:50 EST
Yes, changing it back to LABEL worked and I upgraded to FC3.  Thank
you very much.
Comment 8 Jeremy Katz 2004-12-06 11:20:09 EST
*** Bug 141879 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.