Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1411764 - [NetKVM] Implement VIRTIO_NET_F_GUEST_ANNOUNCE feature in Windows virtio-net driver
Summary: [NetKVM] Implement VIRTIO_NET_F_GUEST_ANNOUNCE feature in Windows virtio-net ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.4
Hardware: Unspecified
OS: Windows
high
medium
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1403896 (view as bug list)
Depends On:
Blocks: 1403896 1431561
TreeView+ depends on / blocked
 
Reported: 2017-01-10 12:35 UTC by Yvugenfi@redhat.com
Modified: 2020-12-14 08:00 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The virtio-win driver now supports the VIRTIO_NET_F_GUEST_ANNOUNCE feature, which, if configured, ensures that ARP packets are recognized by the network when performing live migration of Windows guests. As a result, packet loss during the migration is significantly decreased.
Clone Of:
Environment:
Last Closed: 2017-08-01 12:55:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
Test 29.03 (3.04) summary (212.36 KB, text/plain)
2017-04-04 10:42 UTC, ybendito
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1431561 0 medium CLOSED [NetKVM] Implement VIRTIO_NET_F_GUEST_ANNOUNCE feature in Windows virtio-net driver - IPv6 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:2341 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2017-08-01 16:52:38 UTC

Internal Links: 1431561

Description Yvugenfi@redhat.com 2017-01-10 12:35:53 UTC
Description of problem:

Based on https://bugzilla.redhat.com/show_bug.cgi?id=1403896 there is a high packet loss on Windows after live migration.

Support for the VIRTIO_NET_F_GUEST_ANNOUNCE feature is needed in Windows driver to handle live migration.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 63 ybendito 2017-04-04 10:42:16 UTC
Created attachment 1268602 [details]
Test 29.03 (3.04) summary

Comment 87 Stephen Gordon 2017-05-24 15:11:52 UTC
*** Bug 1403896 has been marked as a duplicate of this bug. ***

Comment 90 Danilo Cesar Lemes de Paula 2017-06-07 19:39:03 UTC
Back to modified as I added this by mistake.

Comment 91 Danilo Cesar Lemes de Paula 2017-06-07 19:46:41 UTC
Is this BZ implemented in the 139 build that I got from MS?

Comment 92 ybendito 2017-06-08 05:53:59 UTC
(In reply to Danilo Cesar de Paula from comment #91)
> Is this BZ implemented in the 139 build that I got from MS?

Yes

Comment 93 Yu Wang 2017-06-08 07:31:40 UTC
Hi Yan and Pierre-André

if this bug can be counted as verified as there is still customer issues?

Thanks
Yu Wang

Comment 94 Pierre-Andre MOREY 2017-06-08 09:26:07 UTC
Hi Yu,

Yes, we are still investigating this bug with customer.

Regards,
Pierre-André

Comment 98 Danilo Cesar Lemes de Paula 2017-06-08 14:29:06 UTC
Can you confirm that? I'm closing the errata buglist.

Comment 111 errata-xmlrpc 2017-08-01 12:55:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341


Note You need to log in before you can comment on or make changes to this bug.