Bug 1411809 - Error while evaluating a Function Call, uninitialized constant RGen::ECore::ELong during upgrade to RHOS-11
Summary: Error while evaluating a Function Call, uninitialized constant RGen::ECore::E...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Sofer Athlan-Guyot
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1468027
TreeView+ depends on / blocked
 
Reported: 2017-01-10 14:44 UTC by Yurii Prokulevych
Modified: 2017-07-05 19:44 UTC (History)
11 users (show)

Fixed In Version: puppet-4.6.2-3.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1468027 (view as bug list)
Environment:
Last Closed: 2017-05-17 19:55:59 UTC


Attachments (Terms of Use)
Undercloud upgrade log (173.67 KB, text/plain)
2017-01-10 14:44 UTC, Yurii Prokulevych
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Yurii Prokulevych 2017-01-10 14:44:38 UTC
Created attachment 1239124 [details]
Undercloud upgrade log

Description of problem:
-----------------------
Attempt to upgrade undercloud from RHOS-10 to RHOS-11 fails with next message:

Error: Evaluation Error: Error while evaluating a Function Call, uninitialized constant RGen::ECore::ELong at /etc/puppet/manifests/puppet-stack-config.pp:17:1 on node undercloud-0.redhat.local

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
puppet                        noarch 4.6.2-2.el7

Steps to Reproduce:
1. Upgrade from RHOS-9 to RHOS-10
2. Try to upgrade undercloud from RHOS-10 to RHOS-11:
    openstack undercloud upgrade

Actual results:
---------------
Upgrade fails


Expected results:
-----------------
Undercloud is upgraded

Comment 1 Sofer Athlan-Guyot 2017-01-10 14:50:49 UTC
Hi,

Puppet is upgraded to version >4.  It now includes its own rgen lib.
But there is some package leftover on rhel plateform that breaks
puppet, namely ruby-rgen-0.6.5-2.el7sat.noarch.

You have to run this before the undercloud upgrade for puppet to continue
to work.

    sudo rpm -e --nodeps ruby-rgen-0.6.5-2.el7sat.noarch

Not sure what is the best course of action here.  Do we :

 - improve packaging to make sure this one is absent (or conflict);
 - integrate it in python-tripleoclient;
 - do a documentation resolution;

Comment 2 Sofer Athlan-Guyot 2017-01-10 15:08:50 UTC
It looks like the best course of action is to add the 

Obsoletes: ruby-rgen 

in the puppet spec file.  Courtesy of mburns.

Waiting for a package to test.

Comment 6 Lon Hohberger 2017-01-10 22:28:04 UTC
Yes, obsoletes is fine here.  The 'ruby-rgen' package appears to have been built specifically for puppet a few years ago, and sort of does a strange unpack/repack of the rgen gem.

Thus, Obsoletes: should be fine.  rubygem-rgen should be used by other apps (if needed).

Comment 10 Sofer Athlan-Guyot 2017-03-22 09:48:21 UTC
Hi,

so could we have the package here, so that we can exclude the issue from what edannon is seeing ?

Adjusting the status.

Thanks.

Comment 12 errata-xmlrpc 2017-05-17 19:55:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.