Bug 1411907 - [RFE] provide the additional disktype for RAID 5
Summary: [RFE] provide the additional disktype for RAID 5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1403772
Blocks: Gluster-HC-3 1417138 1436695 RHHI-1.1-RFEs
TreeView+ depends on / blocked
 
Reported: 2017-01-10 17:38 UTC by SATHEESARAN
Modified: 2017-09-21 04:49 UTC (History)
12 users (show)

Fixed In Version: gdeploy-2.0.2-2
Doc Type: Enhancement
Doc Text:
With this release, RAID5 disk-type is available in gdeploy along with JBOD, RAID6 and RAID10.
Clone Of:
: 1436695 (view as bug list)
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description SATHEESARAN 2017-01-10 17:38:55 UTC
Description of problem:
-----------------------
The disktype currenlty supported by gdeploy are raid6, jbod, raid10

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.1-8.el7rhgs

How reproducible:
-----------------
NA for RFE

Steps to Reproduce:
--------------------
NA for RFE

Actual results:
---------------
There is no disktype for RAID 5

Expected results:
-----------------
Provide the disktype for RAID 5

Comment 1 SATHEESARAN 2017-01-11 17:47:20 UTC
With the conversation with Manoj on the bug 1403772, the computations done for RAID 6 is no different for RAID 5, because gdeploy only looks for 'diskcount', which is the number of data disks.

Comment 2 Sachidananda Urs 2017-01-12 07:26:24 UTC
(In reply to SATHEESARAN from comment #1)
> With the conversation with Manoj on the bug 1403772, the computations done
> for RAID 6 is no different for RAID 5, because gdeploy only looks for
> 'diskcount', which is the number of data disks.

Thanks sas. So, we will have this in next release.

Comment 4 Sachidananda Urs 2017-02-24 07:45:28 UTC
Commit: https://github.com/gluster/gdeploy/commit/feceba5 should fix the issue.

Comment 6 SATHEESARAN 2017-04-24 10:00:25 UTC
Tested with gdeploy-2.0.2-3.el7rhgs
Verified that 'raid5' is accepted as valid disk type by 'gdeploy'.

If illegal RAID type is provided, gdeploy throws proper error message as follows :
"Error: Unsupported disk type!
Only ['raid10', 'raid5', 'raid6', 'jbod'] are supported"

Comment 7 SATHEESARAN 2017-04-24 10:01:08 UTC
The correct fixed-in-version of this bug is gdeploy-2.0.2-2 
Updating the same

Comment 11 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.