Bug 1411925 - HPE [RFE] [Director] Support configuring SRIOV and OVS-DPDK interfaces on the same compute node.
Summary: HPE [RFE] [Director] Support configuring SRIOV and OVS-DPDK interfaces on the...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: All
OS: Linux
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Yariv
QA Contact: Eyal Dannon
URL:
Whiteboard:
: 1457381 1500130 (view as bug list)
Depends On:
Blocks: 1389435 1402132 1442136 1500557 1469601
TreeView+ depends on / blocked
 
Reported: 2017-01-10 18:39 UTC by hrushi
Modified: 2020-09-10 10:06 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:00:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
compute node networking (30.44 KB, image/png)
2017-01-10 18:39 UTC, hrushi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description hrushi 2017-01-10 18:39:16 UTC
Created attachment 1239207 [details]
compute node networking

Description of problem:

HPE's NFV System reference architecture provides choices to customers using either accelerated vSwitch (like OVS-DPDK) or hardware acceleration (using SRIOV or PCI-PT) to achieve line rate performance to their VNF workloads. From hardware perspective, the compute nodes are provisioned with 2 NIC cards with dual ports. 2 ports dedicated for vSwitch and 2 ports for SR-IOV/PCI-PT. With RHOSP10, OSPd supports configuring computes either with OVS-DPDK or OVS + SRIOV-PCI/PT. Compute nodes which are configured with OVS-DPDK are inefficiently used as the remaining 2 ports are just kept idle. The requirement here is to accommodate both hw and sw acceleration on the same compute node to provide effective use of the compute nodes. 

See the attachment for compute node networking.

Comment 3 Franck Baudin 2017-01-27 14:17:24 UTC
Planned for RHOSP12, we may have to push it in RHOSP13 if heavy developments are required in TripleO. But we will evaluate the work to be done in the coming week and provide an update.

Comment 8 atelang 2017-06-08 12:33:45 UTC
*** Bug 1457381 has been marked as a duplicate of this bug. ***

Comment 9 Andreas Karis 2017-06-08 14:41:57 UTC
Hi,

What is the current support status of "upport configuring SRIOV and OVS-DPDK interfaces on the same compute node"

* The templates are obviously coming with Pike (OSP 12) or later?
* Has this been tested without Director - meaning without the templates, only OVS 2.6.1 and SR-IOV combined, does this work right now?

Thanks,

Andreas

Comment 17 Maxim Babushkin 2017-07-24 07:09:14 UTC
Hi Surya,

Could you provide more details regarding the hardware specified on the attached image?

By the image provided, I can see that two interfaces used for the dataplane.
Port 0 from NIC 1 and port 0 from NIC 2 bonded together.

I wonder if the host has one single cpu or multiple cpus?
In case of multiple cpus, the above structure could not be used as it will result in a performance degradation, because the interface cards will probably reside in two different numa nodes.

Thanks,
Maxim.

Comment 18 surya 2017-07-24 11:05:43 UTC
Hi Maxim,


We connected the ports in this way for HA. Even if one intel nic with 2 ports(1.1 and 1.2) goes down we will have connectivity to the VM through the other port from 2nd nic(2.1 and 2.2)

Thanks,
Surya

Comment 21 Franck Baudin 2017-10-25 11:39:01 UTC
*** Bug 1500130 has been marked as a duplicate of this bug. ***

Comment 23 Wei Yongjun 2017-11-09 02:00:20 UTC
Hi,

I assumed nic1 and nic2 are on different NUMA nodes (numa0 and numa1 respectively). In case of SR-IOV, can VM on numa0 use the SR-IOV port on nic2? Is it a must to have across-numa VM deployment for this case?

Thanks,
Yongjun

Comment 24 Franck Baudin 2017-11-09 14:01:01 UTC
Hi Yongjun,

Yes, this is possible. Explanations:
  OVS-DPDK is not NUMA aware, so both NUMA nodes can be used
  SR-IOV is NUMA aware or not depending on how you configures the nova filters
=> OVS-DPDK + SR-IOV will behave like according to SR-IOV NIC with regards to NUMA.

Comment 28 errata-xmlrpc 2017-12-13 21:00:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.