Bug 1412057 - failure to write USB stick, error and Authentication Required
Summary: failure to write USB stick, error and Authentication Required
Keywords:
Status: CLOSED DUPLICATE of bug 1394611
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawriter
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 05:58 UTC by Chris Murphy
Modified: 2017-01-13 09:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
screenshot (1.12 MB, image/jpeg)
2017-01-11 05:58 UTC, Chris Murphy
no flags Details
journalctl (251.47 KB, text/plain)
2017-01-11 06:05 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2017-01-11 05:58:39 UTC
Created attachment 1239323 [details]
screenshot

Description of problem:


Version-Release number of selected component (if applicable):
mediawriter-4.0.7-0.fc25.x86_64

How reproducible:
2 for 2


Steps to Reproduce:
1. Write Fedora-Workstation-Live-x86_64-Rawhide-20170110.n.0.iso to a USB stick
2.
3.

Actual results:

Writes for 5-10 minutes, seems to complete, but then Error just above the progress bar; and then a dialog Authentication Required. Authenticating does nothing, the dialog spinner just spins, no error message. Esc button to back out.

Screenshot shows these things and also the journal entries at the time the error happens (was using journalctl -f during the write)

Expected results:

Should just work, not sure what's going on, this is a regression.


Additional info:


Jan 10 22:47:42 f25h kernel:  sda: sda1 sda2 sda3
Jan 10 22:47:42 f25h dbus-daemon[842]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service' requested by ':1.86' (uid=0 pid=2302 comm="/usr/lib/polkit-1/polkit-agent-helper-1 chris " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
Jan 10 22:47:42 f25h systemd[1]: Starting Fingerprint Authentication Daemon...
Jan 10 22:47:42 f25h dbus-daemon[842]: [system] Successfully activated service 'net.reactivated.Fprint'
Jan 10 22:47:42 f25h systemd[1]: Started Fingerprint Authentication Daemon.
Jan 10 22:47:42 f25h audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 10 22:48:07 f25h mediawriter.desktop[2119]: Warning: Writing failed: "" ((null):0, (null))
Jan 10 22:48:07 f25h polkitd[887]: Operator of unix-session:2 FAILED to authenticate to gain authorization for action org.freedesktop.udisks2.open-device for system-bus-name::1.80 [<unknown>] (owned by unix-user:chris)
Jan 10 22:48:12 f25h audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 10 22:48:44 f25h gnome-shell[1590]: JS ERROR: TypeError: this._session is null
                                        AuthenticationDialog<._onEntryActivate@resource:///org/gnome/shell/ui/components/polkitAgent.js:268
                                        wrapper@resource:///org/gnome/gjs/modules/lang.js:178

Comment 1 Chris Murphy 2017-01-11 06:05:44 UTC
Created attachment 1239324 [details]
journalctl

[   58.772662] Is about when I get started with mediawriter
[   72.115301] Looks like when the writing starts
[  400.763824] This is when I see the Error and dialog.
[  426.052882] This writing failed message is after I've hit the escape button.

Comment 2 Martin Bříza 2017-01-13 09:22:18 UTC

*** This bug has been marked as a duplicate of bug 1394611 ***

Comment 3 Martin Bříza 2017-01-13 09:22:19 UTC

*** This bug has been marked as a duplicate of bug 1394611 ***


Note You need to log in before you can comment on or make changes to this bug.