Bug 1412108 - livecd-iso-to-disk cannot work
Summary: livecd-iso-to-disk cannot work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Yuval Turgeman
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 09:24 UTC by Qin Yuan
Modified: 2017-04-18 03:02 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-07 12:15:04 UTC
oVirt Team: Node
qiyuan: needinfo+
rule-engine: ovirt-4.1+
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1370076 0 medium CLOSED Docs: RHV-H boot via usb device prepared with livecd-iso-to-disk hang with dracut-initqueue[573]: Warning: dracut-initqu... 2021-02-22 00:41:40 UTC

Internal Links: 1370076

Description Qin Yuan 2017-01-11 09:24:40 UTC
Description of problem:
In RHEL 7.3 and Fedora 25, install livecd-tools-20.4-1.6.el7_2.x86_64,
using command livecd-iso-to-disk to write RHVH 4.1 iso to USB failed, error message are as following:

Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done
device node not found
Cleaning up to exit...


In Fedora 25, if install livecd-tools-23.4.1.fc25.x86_64,
it can write RHVH 4.1 iso to USB successfully using livecd-iso-to-disk, but boot from USB failed with error message:

Failed to load ldlinux.c32
Boot failed: please change disks and press a key to continue.


Version-Release number of selected component (if applicable):
RHVH-4.1-20170109.0-RHVH-x86_64-dvd1.iso
livecd-tools-20.4-1.6.el7_2.x86_64 (RHEL 7.3, Fedora 25)
livecd-tools-23.4.1.fc25.x86_64 (Fedora 25)


How reproducible:
100%


Steps to Reproduce:
1. Install livecd-tools-20.4-1.6.el7_2.x86_64 on RHEL 7.3
2. Insert USB, and run command:
   livecd-iso-to-disk --format --reset-mbr RHVH-4.1-20170109.0-RHVH-x86_64-dvd1.iso /dev/sdb

Actual results:
1. After step2, write USB failed with message "device node not found"

Expected results:
1. After step2, the USB is set up with a live image, and this USB can be used to install RHVH 4.1 on a server successfully.

Additional info:

Comment 1 Sandro Bonazzola 2017-01-12 13:39:16 UTC
We had similar issue in bug #1370076. Please try to reproduce.

Comment 2 Yuval Turgeman 2017-01-24 13:48:05 UTC
I managed to reproduce the second bug (Failed to load ldlinux.c32), but not the first one (device node not found).  

It happens for both RHVH iso and other isos as well (Fedora).  The problem is that livecd-iso-to-disk uses mke2fs to create a fs on the target device with an attribute of 64bit, which syslinux does not support:

http://www.syslinux.org/wiki/index.php?title=Filesystem

To solve this, you'd need to run the following after livecd-iso-to-disk:

e2fsck -f /dev/sdb1
resize2fs -b /dev/sdb1

Comment 3 Yuval Turgeman 2017-01-31 09:46:40 UTC
(In reply to Yuval Turgeman from comment #2)
> I managed to reproduce the second bug (Failed to load ldlinux.c32), but not
> the first one (device node not found).  
> 
> It happens for both RHVH iso and other isos as well (Fedora).  The problem
> is that livecd-iso-to-disk uses mke2fs to create a fs on the target device
> with an attribute of 64bit, which syslinux does not support:
> 
> http://www.syslinux.org/wiki/index.php?title=Filesystem
> 
> To solve this, you'd need to run the following after livecd-iso-to-disk:
> 
> e2fsck -f /dev/sdb1
> resize2fs -b /dev/sdb1

resize2fs -s /dev/sdb1 rather...

Comment 4 Yuval Turgeman 2017-02-01 11:48:25 UTC

*** This bug has been marked as a duplicate of bug 1417664 ***

Comment 5 Qin Yuan 2017-04-07 10:40:22 UTC
cmd "livecd-iso-to-disk --format --reset-mbr RHVH.iso /dev/sdx" still returns "device node not found" in RHEL 7.3 with livecd-tools-20.4-1.6.el7_2.x86_64.

"livecd-iso-to-disk" without parameters "--format --reset-mbr" could succeed, but there is another bug 1440075.

QE will mainly focus on "livecd-iso-to-disk" in RHEL, not in Fedora. So reopen this bug to track "livecd-iso-to-disk" with "--format --reset-mbr" in RHEL.

Comment 6 Sandro Bonazzola 2017-04-07 12:15:04 UTC
Qin, if we still see this issue with RHEL's livecd-tools-20.4-1.6.el7_2.x86_64 please clone bug #1417664 to RHEL.
There's nothing we can do on Node side for this.

Comment 7 Qin Yuan 2017-04-18 03:02:06 UTC
As cmd "dd" is the recommended way to write RHVH iso to USB stick, we won't cover "livecd-iso-to-disk" any more.


Note You need to log in before you can comment on or make changes to this bug.