Bug 1417664 - livecd-iso-to-disk creates non bootable disk
Summary: livecd-iso-to-disk creates non bootable disk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 15:21 UTC by Yuval Turgeman
Modified: 2017-03-29 01:29 UTC (History)
9 users (show)

Fixed In Version: livecd-tools-24.2-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-29 01:29:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Yuval Turgeman 2017-01-30 15:21:59 UTC
Description of problem:

After creating a disk from Fedora iso using --format --reset-mbr, booting from the disk shows Failed to load ldlinux.c32

Version-Release number of selected component (if applicable):

livecd-tools-23.4-1.fc25.x86_64
syslinux-6.04-0.1.fc25.x86_64
e2fsprogs-1.43.3-1.fc25.x86_64

Additional info:

e2fsprogs-1.43 now creates by default fs with 64bit feature enabled, and this is not supported by syslinux >= 6.03, this is breaking livecd-iso-to-disk.  Please see:

http://www.syslinux.org/wiki/index.php?title=Filesystem

Comment 1 Neal Gompa 2017-01-30 15:26:10 UTC
Has there been any communication with the syslinux maintainer in Fedora or syslinux upstream about the issue? I would prefer to be able to properly support 64bit ext4 rather than disabling it.

Comment 2 Yuval Turgeman 2017-01-30 15:32:13 UTC
(In reply to Neal Gompa from comment #1)
> Has there been any communication with the syslinux maintainer in Fedora or
> syslinux upstream about the issue? I would prefer to be able to properly
> support 64bit ext4 rather than disabling it.

I really dont know, it only needs to be disabled for /boot I think.

Comment 3 Yuval Turgeman 2017-01-31 08:05:30 UTC
(In reply to Neal Gompa from comment #1)
> Has there been any communication with the syslinux maintainer in Fedora or
> syslinux upstream about the issue? I would prefer to be able to properly
> support 64bit ext4 rather than disabling it.

I think that livecd-iso-to-disk is mostly used to take an iso and copy it onto a usb in order to install, so I dont really think that 64bit is crucial for the installer fs, unless I'm missing something.  Other than that, the previous mke2fs versions did not create 64bit fs, so disabling it in the new version would just keep the original behavior.  I've created a pull request for the small fix:

https://github.com/rhinstaller/livecd-tools/pull/43

Comment 4 Yuval Turgeman 2017-02-01 11:48:25 UTC
*** Bug 1412108 has been marked as a duplicate of this bug. ***

Comment 5 Neal Gompa 2017-03-03 13:14:38 UTC
I have fixed this in the rawhide version livecd-tools v24.1.

Comment 6 Fedora Update System 2017-03-07 14:02:36 UTC
livecd-tools-24.2-1.fc25 appliance-tools-008.0-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7799a1cc7c

Comment 7 Fedora Update System 2017-03-08 14:54:29 UTC
appliance-tools-008.0-3.fc25, livecd-tools-24.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7799a1cc7c

Comment 8 Fedora Update System 2017-03-12 22:46:12 UTC
appliance-tools-008.0-4.fc25 livecd-tools-24.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7799a1cc7c

Comment 9 Fedora Update System 2017-03-14 01:22:46 UTC
appliance-tools-008.0-4.fc25, livecd-tools-24.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7799a1cc7c

Comment 10 Fedora Update System 2017-03-29 01:29:44 UTC
appliance-tools-008.0-4.fc25, livecd-tools-24.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.