Bug 1412197 - Nova misconfigured after upgrade to RHOS-11: ConfigFileValueError: Value for option osapi_compute_workers is not valid
Summary: Nova misconfigured after upgrade to RHOS-11: ConfigFileValueError: Value for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Steven Hardy
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 14:09 UTC by Yurii Prokulevych
Modified: 2017-05-17 19:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:56:30 UTC


Attachments (Terms of Use)
nova.conf (2.74 KB, text/plain)
2017-01-20 08:20 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 405241 None None None 2017-01-24 18:15:29 UTC

Description Yurii Prokulevych 2017-01-11 14:09:34 UTC
Description of problem:
-----------------------
After upgrade to RHOS-11 nova-api fails to start:
2017-01-11 13:56:15.043 521505 CRITICAL nova [req-24c8a525-7062-4aa1-8eef-fb0876106bba - - - - -] ConfigFileValueError: Value for option osapi_compute_workers is not valid: Should be greater than or equal to 1
2017-01-11 13:56:15.043 521505 ERROR nova Traceback (most recent call last):
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/bin/nova-api", line 10, in <module>
2017-01-11 13:56:15.043 521505 ERROR nova     sys.exit(main())
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/lib/python2.7/site-packages/nova/cmd/api.py", line 59, in main
2017-01-11 13:56:15.043 521505 ERROR nova     server = service.WSGIService(api, use_ssl=should_use_ssl)
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/lib/python2.7/site-packages/nova/service.py", line 303, in __init__
2017-01-11 13:56:15.043 521505 ERROR nova     self.workers = (getattr(CONF, '%s_workers' % wname, None) or
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2355, in __getattr__
2017-01-11 13:56:15.043 521505 ERROR nova     return self._get(name)
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2774, in _get
2017-01-11 13:56:15.043 521505 ERROR nova     value = self._do_get(name, group, namespace)
2017-01-11 13:56:15.043 521505 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2817, in _do_get
2017-01-11 13:56:15.043 521505 ERROR nova     % (opt.name, str(ve)))
2017-01-11 13:56:15.043 521505 ERROR nova ConfigFileValueError: Value for option osapi_compute_workers is not valid: Should be greater than or equal to 1
2017-01-11 13:56:15.043 521505 ERROR nova 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-nova-api-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-conductor-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
python-novaclient-6.0.0-1.el7ost.noarch
openstack-nova-console-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-common-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-compute-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-novncproxy-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
python-nova-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-cert-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-scheduler-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
puppet-nova-10.1.0-0.20170105233844.4cb2476.el7ost.noarch

Steps to Reproduce:
1. Upgrade from RHOS-9 to RHOS-10
2. Upgrade from RHOS-10 to RHOS-11
3. Check status of openstack-nova-api on overcloud controllers

Actual results:
---------------
Service fails to start


Expected results:
-----------------
Service is configured during upgrade

Comment 3 Marius Cornea 2017-01-20 08:20:04 UTC
Created attachment 1242666 [details]
nova.conf

I'm attaching nova.conf from an environment which shows the same issue. Note: I wasn't able to complete the Nova upgrade because it's still WIP - https://review.openstack.org/#/c/405241/ . Maybe we need to change these config options to the new required values during the upgrade steps?

Comment 4 Diana Clarke 2017-01-20 15:34:26 UTC
Reassigning to Steven Hardy, as I suspect this will be addressed by the following WIP (see review comments where this bug is mentioned):

 - Add nova service support for composable upgrades
 - https://review.openstack.org/#/c/405241/

Related nova conf change:

 - Backwards incompatible change introduced here:
 - https://review.openstack.org/#/c/332861/13/nova/conf/service.py

Related tripleo bugs:

 - Can't deploy overcloud with ocata/trunk on rhel
 - https://bugs.launchpad.net/tripleo/+bug/1633735

 - nova's osapi_compute_workers is not valid (must be greater than 1)
 - https://bugs.launchpad.net/tripleo/+bug/1631133

Thanks Steven! Do let me know if want/need any help on this front.

Have a great weekend!

Comment 5 Diana Clarke 2017-01-20 15:54:03 UTC
PS. See also:

 - Nova misconfigured after upgrade to RHOS-11: ConfigFileValueError: Value for option metadata_workers is not valid 
 - https://bugzilla.redhat.com/show_bug.cgi?id=1412203

Comment 6 Sofer Athlan-Guyot 2017-03-21 18:40:05 UTC
Hi several patch landed for nova and have landed downstream so I think this bug can be closed, Yurii can you confirm ?

Comment 7 Sofer Athlan-Guyot 2017-03-21 18:42:49 UTC
Sorry, please change "several patch(es) landed for nova" to "the patch landed upstream"

Comment 8 Marius Cornea 2017-03-22 11:29:59 UTC
I think we can consider this as solved as currently the correct configuration gets applied by puppet during the upgrade workflow.

Comment 11 errata-xmlrpc 2017-05-17 19:56:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.