Bug 1412208 - Nova misconfigured after upgrade to RHOS-11: ConfigFileValueError: Value for option metadata_workers is not valid
Summary: Nova misconfigured after upgrade to RHOS-11: ConfigFileValueError: Value for ...
Keywords:
Status: CLOSED DUPLICATE of bug 1412203
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 14:21 UTC by Yurii Prokulevych
Modified: 2017-01-19 17:04 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 17:04:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yurii Prokulevych 2017-01-11 14:21:22 UTC
Description of problem:
-----------------------
After upgrade to RHOS-11 nova-api fails to start:

017-01-11 14:06:36.993 563044 DEBUG nova.wsgi [req-0a75f073-9808-43ea-ace8-9cc89aed8681 - - - - -] Loading app metadata from /etc/nova/api-paste.ini load_app /usr/lib/python2.7/site-packages/nova/wsgi.py:496
2017-01-11 14:06:37.034 563044 CRITICAL nova [req-0a75f073-9808-43ea-ace8-9cc89aed8681 - - - - -] ConfigFileValueError: Value for option metadata_workers is not valid: Should be greater than or equal to 1
2017-01-11 14:06:37.034 563044 ERROR nova Traceback (most recent call last):
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/bin/nova-api", line 10, in <module>
2017-01-11 14:06:37.034 563044 ERROR nova     sys.exit(main())
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/lib/python2.7/site-packages/nova/cmd/api.py", line 59, in main
2017-01-11 14:06:37.034 563044 ERROR nova     server = service.WSGIService(api, use_ssl=should_use_ssl)
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/lib/python2.7/site-packages/nova/service.py", line 303, in __init__
2017-01-11 14:06:37.034 563044 ERROR nova     self.workers = (getattr(CONF, '%s_workers' % wname, None) or
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2355, in __getattr__
2017-01-11 14:06:37.034 563044 ERROR nova     return self._get(name)
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2774, in _get
2017-01-11 14:06:37.034 563044 ERROR nova     value = self._do_get(name, group, namespace)
2017-01-11 14:06:37.034 563044 ERROR nova   File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2817, in _do_get
2017-01-11 14:06:37.034 563044 ERROR nova     % (opt.name, str(ve)))
2017-01-11 14:06:37.034 563044 ERROR nova ConfigFileValueError: Value for option metadata_workers is not valid: Should be greater than or equal to 1
2017-01-11 14:06:37.034 563044 ERROR nova 
2017-01-11 14:06:37.270 563227 INFO oslo_service.service [-] Parent process has died unexpectedly, exiting
2017-01-11 14:06:37.270 563226 INFO oslo_service.service [-] Parent process has died unexpectedly, exiting
2017-01-11 14:06:37.271 563226 INFO nova.wsgi [-] Stopping WSGI server.
2017-01-11 14:06:37.271 563227 INFO nova.wsgi [-] Stopping WSGI server.



Version-Release number of selected component (if applicable):
-------------------------------------------------------------

openstack-nova-scheduler-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-console-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
python-novaclient-6.0.0-1.el7ost.noarch
openstack-nova-compute-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-novncproxy-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
puppet-nova-10.1.0-0.20170105233844.4cb2476.el7ost.noarch
openstack-nova-cert-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-api-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-common-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
openstack-nova-conductor-15.0.0-0.20170106144910.45f14c2.el7ost.noarch
python-nova-15.0.0-0.20170106144910.45f14c2.el7ost.noarch

Steps to Reproduce:
1. Upgrade from RHOS-9 to RHOS-10
2. Upgrade from RHOS-10 to RHOS-11
3. Check status of openstack-nova-api on overcloud controllers

Actual results:
---------------
Service fails to start


Expected results:
-----------------
Service is configured during upgrade

Additional info:
----------------
After manually setting missed variables service has started:
crudini --set /etc/nova/nova.conf DEFAULT metadata_workers 4
crudini --set /etc/nova/nova.conf DEFAULT osapi_compute_workers 4

Comment 1 Eoghan Glynn 2017-01-19 17:04:54 UTC

*** This bug has been marked as a duplicate of bug 1412203 ***


Note You need to log in before you can comment on or make changes to this bug.