Bug 1412489 - Upcall: Possible memleak if inode_ctx_set fails
Summary: Upcall: Possible memleak if inode_ctx_set fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1414654 1414655
TreeView+ depends on / blocked
 
Reported: 2017-01-12 07:17 UTC by Soumya Koduri
Modified: 2017-03-06 17:43 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1414654 1414655 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:43:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Soumya Koduri 2017-01-12 07:17:48 UTC
Description of problem:

In __upcall_inode_ctx_set() if __inode_ctx_set() fails, we should be freeing the allocated inode_ctx. That's not the case now. Thanks Nithya for the pointer.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-01-12 08:53:34 UTC
REVIEW: http://review.gluster.org/16381 (Upcall: Fix possible memleak when inode_ctx_set fails) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 2 Worker Ant 2017-01-12 15:47:27 UTC
COMMIT: http://review.gluster.org/16381 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 84271e12efb783bfc83133329b0fd18aba729c84
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Jan 12 14:19:31 2017 +0530

    Upcall: Fix possible memleak when inode_ctx_set fails
    
    In __upcall_inode_ctx_set(), if inode_ctx_set fails we should
    free allocated memory for ctx. This patch takes care of the same.
    
    Change-Id: Iafb42787151a579caf6f396c9b414ea48d16e6b4
    BUG: 1412489
    Reported-by: Nithya Balachandran <nbalacha@redhat.com>
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/16381
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:43:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.