Bug 1412568 - not able to disable sync plan
Summary: not able to disable sync plan
Keywords:
Status: CLOSED DUPLICATE of bug 1438845
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Sync Plans
Version: 6.2.6
Hardware: All
OS: All
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1415289 1443115 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 10:23 UTC by Anand Agrawal
Modified: 2021-06-10 11:48 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 20:49:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2906831 0 None None None 2017-02-07 22:00:32 UTC

Description Anand Agrawal 2017-01-12 10:23:53 UTC
Description of problem:

When trying to disable a scheduled sync plan (Content -> Sync Plans -> Select Plan -> Change "Sync Enabled" to no) Following error is generated:

An error occurred saving the Sync Plan: undefined method `iso8601' for nil:NilClass

Version-Release number of selected component (if applicable):
6.2.6

How reproducible:
Always

Steps to Reproduce:
1. Create New Sync Plan from Content -> Sync Plans "New Sync Plan"
2. Enter the name for your sync plan.
3. Leave the other field as it is (Interval => Hourly, Start Date => Current Date, Start Time => Current Time)
4. Click the "Save" button to save your sync plan
5. Now on the details page, click on edit icon for Sync Enabled, Change "Sync Enabled" to no
6. Click Save
7. This will throw error 

An error occurred saving the Sync Plan: base Start Date and Time can't be blank

Actual results:

An error occurred saving the Sync Plan: undefined method `iso8601' for nil:NilClass
Expected results:
Sync plan should be allowed to be disabled


Additional info:
As a workaround:
While disabling the Sync Plan, first edit the start time to something in future may be one hour ahead of current time and then try disabling this.

Comment 1 Beat Rubischon 2017-01-24 09:39:17 UTC
*** Bug 1415289 has been marked as a duplicate of this bug. ***

Comment 4 Brad Buckingham 2017-04-18 20:19:18 UTC
*** Bug 1443115 has been marked as a duplicate of this bug. ***

Comment 5 Partha Aji 2017-04-18 20:56:11 UTC
I believe a related issue being addressed in https://bugzilla.redhat.com/show_bug.cgi?id=1438845

If you can confirm the following

Goto "<Username> -> My Accounts" and temporarily change the time zone preferences to use UTC instead of "Browser Locale".

and confirm that works, we can then mark this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1438845


Note You need to log in before you can comment on or make changes to this bug.