Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412954 - regression: editing in command window broken
Summary: regression: editing in command window broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 09:11 UTC by Roman Kagan
Modified: 2017-01-19 05:55 UTC (History)
5 users (show)

Fixed In Version: vim-8.0.176-1.fc25 vim-8.0.194-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 05:55:52 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/vim vim issues 1370 0 None None None 2017-01-13 09:11:35 UTC

Description Roman Kagan 2017-01-13 09:11:36 UTC
Description of problem:

editing in command window doesn't execute the commands and often crashes vim

Version-Release number of selected component (if applicable):

vim-enhanced-8.0.160-1.fc25.x86_64

How reproducible:

always

Steps to Reproduce:
1. open vim
2. type ":some thing like a command" (without <CR>)
3. type Ctrl-F - command window opens
4. edit the command and press <CR>

Actual results:

- the command where the cursor is in the command window fails to execute
- often vim segfaults or aborts

Expected results:
- the command editing succeeds and the command is executed

Additional info:

the problem has been fixed in upstream v8.0.0172 (and introduced in v8.0.0159)

Comment 1 Zdenek Dohnal 2017-01-13 09:27:43 UTC
Hi Roman,

thanks for letting me know, I was waiting for 8.0.160 reaching f24 stable, but if it broke vim, I will obsolete it. Newest commits will be built today (the newest commits are in fedora git, but I did not build package).

Comment 2 Fedora Update System 2017-01-13 11:14:34 UTC
vim-8.0.176-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-dcb7e7cd0f

Comment 3 Fedora Update System 2017-01-14 06:21:06 UTC
vim-8.0.176-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-dcb7e7cd0f

Comment 4 Roman Kagan 2017-01-16 07:27:25 UTC
vim-enhanced-8.0.176-1.fc25.x86_64 still crashes on me, and the command editing window doesn't work as expected.

This is weird because vim built from upstream git (with default config though) started to work.

I'll take further look and let you know what can be the culprit.

Comment 5 Roman Kagan 2017-01-16 08:19:15 UTC
Looks like something is broken in your upstream source import: your vim-8.0-176.tar.bz2 is significantly different from upstream:

# git remote -v
origin  https://github.com/vim/vim.git (fetch)
origin  https://github.com/vim/vim.git (push)
# git describe --tags
v8.0.0176
# git reset --hard
HEAD is now at 70bcd73 patch 8.0.0176: cannot use :change inside a function definition
# git clean -f -x -d
# tar -xf ~/work/git/fedpkg/vim/vim-8.0-176.tar.bz2 --strip-components=1
# git diff --stat
 runtime/doc/develop.txt         |   4 +-
 runtime/doc/eval.txt            |   6 +-
 runtime/doc/filetype.txt        |   4 +-
 runtime/doc/intro.txt           |  11 +-
 runtime/doc/todo.txt            |  80 ++---
 src/testdir/README.txt          |   6 +-
 src/Makefile                    |   1 -
 src/os_unixx.h                  |   2 +-
 src/vim.h                       |   2 -
 src/channel.c                   |   5 +-
 src/charset.c                   |   2 +-
 src/eval.c                      |  34 +-
 src/evalfunc.c                  |  46 ++-
 src/ex_cmds2.c                  |  34 +-
 src/ex_getln.c                  |  11 +-
 src/getchar.c                   |  21 +-
 src/gui_gtk.c                   |   3 -
 src/gui_gtk_x11.c               |   3 -
 src/if_ruby.c                   |   3 +-
 src/json.c                      | 697 ++++++++++++++++------------------------
 src/json_test.c                 |   2 +-
 src/list.c                      |   2 +-
 src/mbyte.c                     |  43 ++-
 src/misc1.c                     |   3 -
 src/misc2.c                     |   2 +-
 src/os_win32.c                  | 130 +-------
 src/regexp_nfa.c                |   4 +-
 src/userfunc.c                  |   7 +-
 src/version.c                   |  32 --
 runtime/doc/tags                |   6 +-
 runtime/filetype.vim            |   7 +-
 runtime/ftplugin/man.vim        |   3 +-
 runtime/indent/javascript.vim   | 388 +++++++---------------
 runtime/syntax/html.vim         |   7 +-
 src/proto/os_win32.pro          |   2 -
 src/testdir/test_alot.vim       |   1 -
 src/testdir/test_float_func.vim |  53 ---
 src/testdir/test_history.vim    |  17 -
 src/testdir/test_json.vim       |   8 +-
 src/testdir/test_viml.vim       |  71 ----
 40 files changed, 591 insertions(+), 1172 deletions(-)

Vim built from upstream is ok, the one built from the tarball has the bug.

Comment 6 Fedora Update System 2017-01-16 12:24:21 UTC
vim-8.0.194-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-dc6a3a97b3

Comment 7 Zdenek Dohnal 2017-01-16 12:28:21 UTC
Roman, would you mind trying this new build https://koji.fedoraproject.org/koji/buildinfo?buildID=834108 ? I hope it will be alright this time.

Comment 8 Roman Kagan 2017-01-16 14:13:46 UTC
This one seems to work.

(And the sources are in sync with upstream ;)

Thank you, will post the karma on bodhi, too.

Comment 9 Fedora Update System 2017-01-16 19:51:35 UTC
vim-8.0.176-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-01-16 22:24:02 UTC
vim-8.0.194-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-dc6a3a97b3

Comment 11 Fedora Update System 2017-01-19 05:55:52 UTC
vim-8.0.194-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.