Bug 141298 - [httx] with xft terminates when X application using XIMStatusArea
[httx] with xft terminates when X application using XIMStatusArea
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
: 153005 (view as bug list)
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-11-30 02:21 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 12.1-10.FC3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 04:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-11-30 02:21:38 EST
Description of problem:
Emacs by default displays its XIM status on the right hand side
of the minibuffer in a XIMStatusArea window.  With the current
Xft patch used for iiimxcf, httx exits with a X error when
it is activated from Emacs (without
emacs-xim-status-under-window-125413.patch).

Version-Release number of selected component (if applicable):
emacs-21.3-18

How reproducible:
everytime

Steps to Reproduce:
1. Start emacs in fc2 or fc3 with httx as the xim client
2. Press C-Space
3. Press C-Space again
  
Actual results:
2. httx terminates with:
X Error of failed request:  BadDrawable (invalid Pixmap or Window
parameter)
  Major opcode of failed request:  155 (RENDER)
  Minor opcode of failed request:  4 (RenderCreatePicture)
  Resource id in failed request:  0x0
  Serial number of failed request:  383
  Current serial number in output stream:  394

3. Mark is set.

Expected results:
2. XIM to be activated with status on right of minibuffer.

Additional info:
See also bug 125413 where emacs-xim-status-under-window-125413.patch
was used to workaround this problem for more details.
Comment 1 Akira TAGOH 2005-04-04 08:24:26 EDT
*** Bug 153005 has been marked as a duplicate of this bug. ***
Comment 2 Akira TAGOH 2005-04-04 08:26:17 EDT
This problem seems to be not an emacs specific problem. it happens on the Motif
applications too. changing a summary.
Comment 3 Akira TAGOH 2005-04-25 23:39:57 EDT
should be fixed in 12.1.1-15.svn2509 or later.
Comment 4 Lawrence Lim 2005-06-27 02:13:25 EDT
Tested with iiimf-12.2-5, confirm this has been fixed. Please proceed with
creating a new im-sdk package for FC3-updates.

Thanks.
Comment 5 Akira TAGOH 2005-07-28 10:45:28 EDT
This problem should be fixed in 12.1-10.FC3.1.

Note You need to log in before you can comment on or make changes to this bug.