Bug 141305 - Warning messages when starting
Warning messages when starting
Status: CLOSED DUPLICATE of bug 143678
Product: Fedora
Classification: Fedora
Component: redhat-config-samba (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
Depends On:
  Show dependency treegraph
Reported: 2004-11-30 04:43 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-18 10:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2004-11-30 04:43:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
When starting system-config-samba some warning messages appear, but
functionality appears unharmed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start KDE
2. Start Kterm
3. su
4. Type system-config-samba

Actual Results:  /usr/share/system-config-samba/mainWindow.py:113:
DeprecationWarning: use gtk.UIManager
  item_fac = gtk.ItemFactory(gtk.MenuBar, "<main>", accel_group)
/usr/share/system-config-samba/mainWindow.py:138: DeprecationWarning:
  button = self.toolbar.insert_stock('gtk-add', _("Add a samba
share"), None, self.onNewButtonClicked, None, 0)
/usr/share/system-config-samba/mainWindow.py:143: DeprecationWarning:
  self.properties_button = self.toolbar.insert_stock('gtk-properties',
_("Editthe properties of the selected directory"), None,
self.onPropertiesButtonClicked, None, 1)
/usr/share/system-config-samba/mainWindow.py:148: DeprecationWarning:
  self.delete_button = self.toolbar.insert_stock('gtk-delete',
_("Delete the selected directory"), None, self.onDeleteButtonClicked,
None, 2)
/usr/share/system-config-samba/mainWindow.py:153: DeprecationWarning:
  self.toolbar.insert_stock('gtk-help', _("View help"), None,
self.onHelpClicked, None, 3)

Expected Results:  No warnings should appear.

Additional info:
Comment 1 Patricio Carr 2005-02-15 03:26:07 EST
  A bit of hacking with pygtk got this bug fixed. Running
system-config-samba V.1.2.26 on FC3. PyGTK >= 2.4 is needed.
  Patch at http://patocarr.com/mainWindow.patch

  Duplicated: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143678
Comment 2 Nils Philippsen 2005-03-10 09:15:13 EST

*** This bug has been marked as a duplicate of 143678 ***

Note You need to log in before you can comment on or make changes to this bug.