Bug 143678 - Warning message on start up
Warning message on start up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
:
: 141305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-23 17:22 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 10:24:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2004-12-23 17:22:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.3)
Gecko/20041207

Description of problem:
Warning messages appear whenever the program is started.

Version-Release number of selected component (if applicable):
system-config-samba-1.2.22-0.fc3.1

How reproducible:
Always

Steps to Reproduce:
1. Start KDE
2. Start in terminal
3. Type system-config-samba
    

Actual Results:  sr/share/system-config-samba/mainWindow.py:113:
DeprecationWarning: use gtk.UIManager
  item_fac = gtk.ItemFactory(gtk.MenuBar, "<main>", accel_group)
/usr/share/system-config-samba/mainWindow.py:138: DeprecationWarning:
  button = self.toolbar.insert_stock('gtk-add', _("Add a samba
share"), None, self.onNewButtonClicked, None, 0)
/usr/share/system-config-samba/mainWindow.py:143: DeprecationWarning:
  self.properties_button = self.toolbar.insert_stock('gtk-properties',
_("Edit the properties of the selected directory"), None,
self.onPropertiesButtonClicked, None, 1)
/usr/share/system-config-samba/mainWindow.py:148: DeprecationWarning:
  self.delete_button = self.toolbar.insert_stock('gtk-delete',
_("Delete the selected directory"), None, self.onDeleteButtonClicked,
None, 2)
/usr/share/system-config-samba/mainWindow.py:153: DeprecationWarning:
  self.toolbar.insert_stock('gtk-help', _("View help"), None,
self.onHelpClicked, None, 3)


Expected Results:  No warning messages

Additional info:
Comment 1 Nils Philippsen 2004-12-29 05:20:58 EST

*** This bug has been marked as a duplicate of 134367 ***
Comment 2 Patricio Carr 2005-02-15 03:16:46 EST
Nils,

  A bit of hacking with pygtk got this bug fixed. Running
system-config-samba V.1.2.26 on FC3. PyGTK >= 2.4 is needed.
  Patch at http://patocarr.com/mainWindow.patch
Comment 3 Nils Philippsen 2005-02-16 08:50:00 EST
Reopening to keep track of FC3 and RHEL4 stuff separately.
Comment 4 Nils Philippsen 2005-02-16 08:53:04 EST
Patricio,

your patch unfortunately doesn't mark translatable strings for translation and
of course doesn't on older pygtk versions. I'll extend your patch by these
things, but could you please submit it in unified format next time ("diff -u")?
It's so much more readable.
Comment 5 Nils Philippsen 2005-02-16 10:31:05 EST
Umm, forgot: thanks for the patch, though ;-).
Comment 6 Nils Philippsen 2005-03-10 09:15:20 EST
*** Bug 141305 has been marked as a duplicate of this bug. ***
Comment 7 Nils Philippsen 2005-03-18 10:24:04 EST
Fixed in system-config-samba-1.2.27-0.fc3.1.

Note You need to log in before you can comment on or make changes to this bug.