Bug 141306 - missing rpm dependencies on many python packages
missing rpm dependencies on many python packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
: 139840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 05:16 EST by Avi Kivity
Modified: 2014-01-21 17:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 22:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2004-11-30 05:16:07 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
many python packages (for instance, yum) install files 
in /usr/lib/python2.x/site-packages. if either the python package is 
updated, or the package which installed files 
into /usr/lib/python2.x/site-packages is updated, things stop working 
immediately because the python sys.path no longer includes the 
site-packages directory. 
 
clearly, if a package installs things into python2.x/site-packages, 
it should require python-2.x in its rpm dependencies 
 
Version-Release number of selected component (if applicable): 
yum-2.1.11-4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. start with fedora core 3 
2. add the fc-devel repository 
3. yum update yum 
4. yum list recent 
     
Note: using yum as an example, but probably many other python 
packages suffer from the problem. 
 
Actual Results:  yum breaks with failures to import its own modules 
 
Expected Results:  yum works 
 
Additional info: 
 
marking as high priority, since the method to fix the problem 
(running yum) is broken by the bug...
Comment 1 Jeremy Katz 2004-11-30 18:58:58 EST
(reassigning to distribution as this really needs to be solved
generically for everything and not just in yum)
Comment 2 Bill Nottingham 2004-11-30 20:45:41 EST
Jeff had mentioned implementing this in find-requires at one point,
unless I misheard.
Comment 3 Jeff Johnson 2004-11-30 23:14:41 EST
Nope, you heard correct. Getting there, I want to hand off
all the python macros to python-devel same time ...
Comment 4 Jeff Johnson 2004-12-06 23:11:36 EST
Changes to emit
    Requires: python(abi) = 2.4
are in rpm CVS, should be in rpm-4.3.3-8 when built.
Comment 5 Jeff Johnson 2004-12-07 11:47:59 EST
*** Bug 139840 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Johnson 2004-12-07 22:44:17 EST
python-2.4-2 and rpm-4.3.3-8 adds
    Requires: python(abi) = 2.4
to every package that contains /usr/lib*/python2.4

Note that it will take a while to deploy this fix, because
every python package will need to be rebuilt in order for the
change to take effect. Please report bugs against individual
packages, as rpm can only rebuild as fast as its is invoked.

Note You need to log in before you can comment on or make changes to this bug.