Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413283 - glusterfs-server postinstall script error about 'fi'
Summary: glusterfs-server postinstall script error about 'fi'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glusterfs
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1414412 (view as bug list)
Depends On: 1410854
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-14 12:58 UTC by Jon Burgess
Modified: 2017-01-20 17:54 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.9.0-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 17:54:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Jon Burgess 2017-01-14 12:58:53 UTC
Description of problem:
Updating to the latest glusterfs-server package triggered a non-fatal postinst script error

Version-Release number of selected component (if applicable):
glusterfs-server-3.9.0-2.fc25.x86_64

How reproducible:
Once

Steps to Reproduce:
1. update to latest package
2.
3.

Actual results:
Didn't take a copy of exact wording, something like "postinstall script error unmatched fi on line 47"

Expected results:
no error

Additional info:
Seems to have been introduced by c1dc434:

 %if (0%{?_with_firewalld:1})
-#reload service files if firewalld running
-if $(systemctl is-active firewalld 1>/dev/null 2>&1); then
-  #firewalld-filesystem is not available for rhel7, so command used for reload.
-  firewall-cmd  --reload 1>/dev/null 2>&1
+    %firewalld_reload
 fi
 %endif

The last "fi" above should have been deleted as well.

Comment 1 Niels de Vos 2017-01-15 10:08:25 UTC
This has been fixed in upstream with http://review.gluster.org/16409

3.9.1 is getting released soon (within a few days?) and this bug will be fixed with that update. Because this is only a warning on the last line of the scriptlet, it is not critical and there isn't an update of the package needed to address this problem immediately.

Comment 2 Fedora Update System 2017-01-16 15:39:35 UTC
glusterfs-3.9.0-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7bdfd38ad1

Comment 3 Fedora Update System 2017-01-16 22:25:02 UTC
glusterfs-3.9.0-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7bdfd38ad1

Comment 4 Richard W.M. Jones 2017-01-18 12:47:16 UTC
*** Bug 1414412 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2017-01-20 17:54:28 UTC
glusterfs-3.9.0-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.