Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410854 - glusterfs-server should depend on firewalld-filesystem
Summary: glusterfs-server should depend on firewalld-filesystem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1410853
Blocks: 1413283
TreeView+ depends on / blocked
 
Reported: 2017-01-06 15:55 UTC by Niels de Vos
Modified: 2017-03-08 10:24 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410853
Environment:
Last Closed:
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2017-01-06 15:55:29 UTC
+++ This bug was initially created as a clone of Bug #1410853 +++

+++ This bug was initially created as a clone of Bug #1410852 +++

Description of problem:
Recently RHEL7 was rebased to have firewalld-filesystem available. Because the glusterfs-server RPM installs a .xml file with firewalld rules, this RPM needs to depend on the RPM that provides the directory for the .xml files.

Version-Release number of selected component (if applicable):
3.8 and newer

Additional info:
The glusterfs.spec.in currently tries to execute "firewall-cli --reload". The correct way is to call the %firewalld_reload macro from /usr/lib/rpm/macros.d/macros.firewalld (provided by firewalld-filesystem).

Comment 1 Worker Ant 2017-01-10 09:49:25 UTC
REVIEW: http://review.gluster.org/16369 (rpm: depend on firewalld-filesystem for directory ownership) posted (#1) for review on release-3.9 by Niels de Vos (ndevos@redhat.com)

Comment 2 Worker Ant 2017-01-10 09:54:17 UTC
REVIEW: http://review.gluster.org/16369 (rpm: depend on firewalld-filesystem for directory ownership) posted (#2) for review on release-3.9 by Niels de Vos (ndevos@redhat.com)

Comment 3 Worker Ant 2017-01-12 16:07:27 UTC
COMMIT: http://review.gluster.org/16369 committed in release-3.9 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 60acdbd87a2c3d5bf1b199b91a7d154467fe1b79
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Jan 10 10:49:07 2017 +0100

    rpm: depend on firewalld-filesystem for directory ownership
    
    Also use the %firewalld_reload macro that is provided by the
    firewalld-filesystem package.
    
    Cherry picked from commit f99750b4477538cd1f97ce6340e1813202f986e2:
    > BUG: 1410853
    > Change-Id: Ibbbc18cc394f8b1e5ba74927effc41c466667479
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/16351
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    Change-Id: Ibbbc18cc394f8b1e5ba74927effc41c466667479
    BUG: 1410854
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/16369
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Worker Ant 2017-01-13 13:36:31 UTC
REVIEW: http://review.gluster.org/16409 (rpm: fix glusterfs-server(%postun) scriptlet error) posted (#1) for review on release-3.9 by Niels de Vos (ndevos@redhat.com)

Comment 5 Worker Ant 2017-01-13 20:16:55 UTC
COMMIT: http://review.gluster.org/16409 committed in release-3.9 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit f8a61095fc7003b97960d3097cfa2b6a3ad9fe43
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 13 14:31:27 2017 +0100

    rpm: fix glusterfs-server(%postun) scriptlet error
    
    While introducing the usage of the %firewalld_restart macro, the old
    scriplet was not correctly removed. This causes an error to be displayed
    when the RPM gets updated or uninstalled.
    
    Cherry picked from commit e3d09359b2090c0dc9160b693969f69ecda3477c:
    > Fixes: f99750b4477538cd1f97ce6340e1813202f986e2
    > Change-Id: I69091d8e9e3c412dc3cb52246967eac29d2ebc90
    > BUG: 1410853
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    
    Fixes: 60acdbd87a2c3d5bf1b199b91a7d154467fe1b79
    Change-Id: I69091d8e9e3c412dc3cb52246967eac29d2ebc90
    BUG: 1410854
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/16409
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 6 Kaushal 2017-03-08 10:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.1, please open a new bug report.

glusterfs-3.9.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-January/029725.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 7 Kaushal 2017-03-08 10:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.1, please open a new bug report.

glusterfs-3.9.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-January/029725.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.