Bug 1413788 - rhn-satellite-activate and satellite-sync: add pointer to new command and/or option for customers when they try run the old ones
Summary: rhn-satellite-activate and satellite-sync: add pointer to new command and/or ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 580
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Jan Hutař
URL:
Whiteboard:
: 1399627 1415188 (view as bug list)
Depends On:
Blocks: 465198 1340444
TreeView+ depends on / blocked
 
Reported: 2017-01-17 00:19 UTC by Xixi
Modified: 2017-06-21 12:18 UTC (History)
9 users (show)

Fixed In Version: spacewalk-backend-2.5.3-58-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1418044 (view as bug list)
Environment:
Last Closed: 2017-06-21 12:18:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xixi 2017-01-17 00:19:59 UTC
Description of problem:

Satellite 5.8 with CDN sync includes new tooling (commands/options) to activate Satellite and sync content, among other things.   We need to include informative messaging for customers to use the new command/options when they run the old ones from memory, to save some unnecessary support calls.  (We did this for Satellite 6 with new install options).

* If a user runs satellite-sync against RHN, the command should display a message (instead of the current warning "this is disabled") saying please use cdn-sync instead to sync content (with summary or link to docs for registration and Manifest generation).
* if a user runs rhn-satellite-activate with the --rhn-cert option, the cmd should advise customer to use --manifest option with manifest file.

Version-Release number of selected component (if applicable):
Satellite 5.8 (Beta and GA)

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Gennadii Altukhov 2017-01-25 09:12:52 UTC
*** Bug 1415188 has been marked as a duplicate of this bug. ***

Comment 3 Gennadii Altukhov 2017-01-25 15:03:00 UTC
Patch is available in upstream. spacewalk.git:
b15ddc7de9eac51b4bd9874b7d53beb2f1e1caef


1) for satellite-sync added a mention about cdn-sync if someone tries to sync from RHN, with small summary (I wouldn't like to hardcode some links to documentation in our code)

# satellite-sync -c rhel-x86_64-server-6 
...
15:47:51 ERROR: Synchronizing from RHN is no longer supported. Please register to RHSM and use cdn-sync

2) for rhn-satellite-activate added error message if --rhn-cert option was provided.

# rhn-satellite-activate --rhn-cert cert-file.xml

ERROR: Activation with RHN certificate is deprecated. Run the activation tool with option --manifest=MANIFEST.



Xixi, please, review the error messages and if you would like to improve/add something let me know.

Comment 4 Xixi 2017-01-30 23:57:06 UTC
(In reply to Gennadii Altukhov from comment #3)
> Patch is available in upstream. spacewalk.git:
> b15ddc7de9eac51b4bd9874b7d53beb2f1e1caef
> 
> Xixi, please, review the error messages and if you would like to improve/add
> something let me know.

Thanks Gennadii, pls find suggested revisions below in-line.  Defer to you and Tomas/Grant/team for technical accuracy.

> 
> 1) for satellite-sync added a mention about cdn-sync if someone tries to
> sync from RHN, with small summary (I wouldn't like to hardcode some links to
> documentation in our code)
> 
> # satellite-sync -c rhel-x86_64-server-6 
> ...
> 15:47:51 ERROR: Synchronizing from RHN is no longer supported. Please
> register to RHSM and use cdn-sync
> 

Propose to change this message to:
"Live content synchronizing with RHN Classic Hosted is no longer supported. Please use the cdn-sync command instead unless you are attempting to sync from another Satellite via Inter-Satelite-Sync (ISS), or from local content on disk via Channel Dump ISOs."

> 2) for rhn-satellite-activate added error message if --rhn-cert option was
> provided.
> 
> # rhn-satellite-activate --rhn-cert cert-file.xml
> 
> ERROR: Activation with RHN certificate is deprecated. Run the activation
> tool with option --manifest=MANIFEST.
> 

Propose to change this message to:
"Activation with RHN Classic Satellite Certificate is deprecated. Please obtain a Manifest for this Satellite version via https://access.redhat.com/knowledge/tools/satcert, and re-run this activation tool with option --manifest=MANIFEST-FILE."

The https://access.redhat.com/knowledge/tools/satcert used here is a special content type created especially for the Sat Cert tooling, so that the static url does not change.

In addition to the --rhn-cert file, does the detection logic also cover the other criteria mentioned in discussion thread like "* not-registered-to-rhsm * using an old sat5-XML-cert file"?

And adding 3) per Grant's suggestion in Comment 1: 
For cdn-sync, if customer is trying to sync from Content ISO or ISS, then display this message:
"This tool is for live synchronization of content. Please use the satellite-sync command to sync from another Satellite via Inter-Satelite-Sync (ISS), or from local content on disk via Channel Dump ISOs."

Grant/Tomas - does that cover everything from the thread?

Comment 5 Grant Gainey 2017-01-31 15:27:59 UTC
1 and 2 look good.

RE 3 - so first, there's no way to point cdn-sync at an ISO, so that isn't an issue. However, the ISS piece brings up a good point.

Pre-cdn-sync, we can only get content one way, which is using satellite-sync. satellite-sync can only get its content from one place, which is server.satellite.rhn_parent.

With cdn-sync, we've opened the door to getting content in *two* ways - satellite-sync (ISS), and cdn-sync (from Red Hat). I think we need to teach cdn-sync to notice when its satellite is NOT pointing to redhat.com, and either a) refuse to work in that case, or b) require a specific override option to grab content from the CDN. Otherwise, we're potentially letting the customer break their desired ISS topology.

This would be its own BZ, I think - because it's going to require some thought, and code-changes. I'm suggesting that Gennadii open a new 5.8-GA BZ for that work, while making the changes for 1) and 2) under this BZ.

Sound good, everyone?

Comment 6 Gennadii Altukhov 2017-01-31 17:01:06 UTC
1 and 2 fixed in upstream. 
spacewalk.git:
80539ed66712efb676cf45d89af823f7ec3897d8


for 3 created BZ 1418044

Comment 7 Xixi 2017-02-01 21:09:16 UTC
Sounds good, thank you Grant / Gennadii!

Comment 11 Jan Dobes 2017-05-18 14:12:11 UTC
*** Bug 1399627 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.