Bug 1413857 - mock-1.3.3-1.el7.noarch requires python2-distro
Summary: mock-1.3.3-1.el7.noarch requires python2-distro
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1414230 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 07:32 UTC by Lukas Slebodnik
Modified: 2017-01-18 11:57 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 11:47:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Slebodnik 2017-01-17 07:32:09 UTC
Description of problem:
I cannot install mock from epel7

Version-Release number of selected component (if applicable):
mock-1.3.3-1.el7.noarch

How reproducible:
Deterministic

Steps to Reproduce:
//tested on CentOS 7
1. yum install -y --debuglevel=1 epel-release
2. yum install -y --debuglevel=1 mock

Actual results:
Error: Package: mock-1.3.3-1.el7.noarch (epel)
           Requires: python2-distro
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Package is installed without any problem

Additional info:
Neither python2-distro nor python-distro is available in EPEL7
sh# yum install -y --debuglevel=1 python2-distro python-distro
Error: Nothing to do

Comment 1 Lukas Slebodnik 2017-01-17 07:37:57 UTC
I've just realized that python2-distro-1.0.1-2.el7.noarch is still just in epel-testing (because it's a new package)

Comment 2 Miroslav Suchý 2017-01-17 08:20:15 UTC
Yes. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2d4b482b6f
I should push it to stable tomorrow (it need to be there for 14 day or have 3 karma points).

Comment 3 Miroslav Suchý 2017-01-18 11:47:02 UTC
It has been pushed to stable yesterday evening.

Comment 4 Miroslav Suchý 2017-01-18 11:57:57 UTC
*** Bug 1414230 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.