Bug 1413973 - [ovirt-aaa-jdbc-tool] show descriptive message when trying to show non existence group
Summary: [ovirt-aaa-jdbc-tool] show descriptive message when trying to show non existe...
Keywords:
Status: CLOSED DUPLICATE of bug 1415704
Alias: None
Product: ovirt-engine-extension-aaa-jdbc
Classification: oVirt
Component: Core
Version: 1.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.1
: ---
Assignee: Ondra Machacek
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 13:21 UTC by Tareq Alayan
Modified: 2017-02-06 10:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 10:29:23 UTC
oVirt Team: Infra
rule-engine: ovirt-4.1+


Attachments (Terms of Use)

Description Tareq Alayan 2017-01-17 13:21:17 UTC
Description of problem:
The error message is not user friendly 

Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-jdbc-1.1.2-1.el7ev.noarch
ovirt-engine-4.1.0-0.3.beta2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. run the command ovirt-aaa-jdbc-tool group show  nonexistgroup
2.
3.

Actual results:
Jan 17, 2017 3:19:09 PM org.ovirt.engine.extension.aaa.jdbc.binding.cli.Cli main
SEVERE: Unexpected Exception invoking Cli: java.lang.String cannot be cast to [Ljava.lang.Object;

Expected results:
This group 'nonexistgroup' not found :) 

Additional info:

Comment 1 Ondra Machacek 2017-02-06 10:29:23 UTC

*** This bug has been marked as a duplicate of bug 1415704 ***


Note You need to log in before you can comment on or make changes to this bug.