Bug 1414100 - Wrong NFS version selected by default
Summary: Wrong NFS version selected by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.2
Assignee: Tal Nisan
QA Contact: Avihai
URL:
Whiteboard:
: 1162635 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 18:36 UTC by jniederm
Modified: 2017-02-01 14:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:53:29 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 70699 master MERGED webadmin: Select NFS version auto negotiate when creating new domain 2017-01-18 08:33:50 UTC
oVirt gerrit 70709 ovirt-engine-4.1 MERGED webadmin: Select NFS version auto negotiate when creating new domain 2017-01-18 08:35:25 UTC

Description jniederm 2017-01-17 18:36:19 UTC
Description of problem:
When adding new NFS storage domain, the dialog contains (by default hidden) option "NFS version" that has by default value "v3" which is incompatible with nfs server running on Fedora 24. The error error dialog that pops up (after quite a while) states:
"Error while executing action Add Storage Connection: Problem while trying to mount target"
I.e. it doesn't mention that the problem might be in wrong NFS version.

Version-Release number of selected component (if applicable):
4.2 master, commit 94e107d

How reproducible:
100%

Steps to Reproduce:
1. Storage tab > New Domain
2. Fill in necessary fields to add NFS storage domain, leave default ("v3") in nfs version
3. Click OK and wait

Actual results:
Error dialog pops up

Expected results:
"Auto Negotiate" option is selected by default in "NFS Version" field. I allows user to actually don't care much about that field as suggested by the fact that it's hidden by default.

Additional info:

Comment 1 Tal Nisan 2017-01-18 11:48:39 UTC
*** Bug 1162635 has been marked as a duplicate of this bug. ***

Comment 2 Avihai 2017-01-22 13:49:44 UTC
verified on :

Engine:
ovirt-engine-4.1.0.1-0.4.master.20170118134729.gitf34da1f.el7.centos.noarch

Vdsm:
4.19.2-1


Note You need to log in before you can comment on or make changes to this bug.