Bug 1414243 - nagios-plugins-file_age ceases to work with the update to 2.1.4-2.el6
Summary: nagios-plugins-file_age ceases to work with the update to 2.1.4-2.el6
Keywords:
Status: CLOSED DUPLICATE of bug 1410039
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 07:06 UTC by Christoph Galuschka
Modified: 2017-01-18 13:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 13:39:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Christoph Galuschka 2017-01-18 07:06:55 UTC
Description of problem:
nagious-plugins-file_age ceases to work with the update to 2.1.4-2.el6. Since this update, no matter which file I check, the plugin always returns "File not found".

Version-Release number of selected component (if applicable):
2.1.4-2.el6

How reproducible:
always

Steps to Reproduce:
1. Install nagios-plugins-all
2. run /usr/lib64/nagois/plugins/check_file_age somefile
3. result is "File not found"

Actual results:
/usr/lib64/nagios/plugins # ./check_file_age check_file_age 
FILE_AGE CRITICAL: File not found - "check_file_age"

Expected results:
./check_file_age check_file_age 
FILE_AGE OK: check_file_age is 1 seconds old and 3844 bytes  | age=1s;240;600 size=3844B;0;0;0

Additional info:
The issues seems to be the command in line 80:
>>
$opt_f = '"' . $opt_f . '"';
>>
This adds "" to the filename, which does not work. Commenting that line out fixes the issue.

Comment 1 Scott Wilkerson 2017-01-18 13:39:18 UTC

*** This bug has been marked as a duplicate of bug 1410039 ***


Note You need to log in before you can comment on or make changes to this bug.