Bug 1410039 - check_file_age is broken in recent update
Summary: check_file_age is broken in recent update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: el6
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1410055 1414243 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 10:07 UTC by Matthias Hensler
Modified: 2017-06-30 03:17 UTC (History)
15 users (show)

Fixed In Version: nagios-plugins-2.1.4-3.el6 nagios-plugins-2.1.4-3.fc24 nagios-plugins-2.2.1-1.fc25 nagios-plugins-2.2.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-29 23:49:32 UTC


Attachments (Terms of Use)

Description Matthias Hensler 2017-01-04 10:07:12 UTC
Description of problem:
After updating nagios-plugins this night, all of our checks using the check_file_age-plugins are broken.

Version-Release number of selected component (if applicable):
2.1.4-2.el6


Steps to Reproduce:
1. touch /tmp/test
2. /usr/lib64/nagios/plugins/check_file_age -f /tmp/test

Actual results:
 FILE_AGE CRITICAL: File not found - "/tmp/test"

Expected results:
 FILE_AGE OK: /tmp/test is 2 seconds old and 0 bytes  | age=2s;240;600 size=0B;0;0;0 


Additional info:
Upstream added a fix to allow checking of filenames including spaces. However, that fix breaks all filenames which do not include spaces.

The upstream bug is discussed here: https://github.com/nagios-plugins/nagios-plugins/issues/213

As the current version break existing checks in a horrible way you might consider of either rolling back to the old version of check_file_age, or fixing this issue downstream (depending on how long upstream needs to fix and push a new release).

Comment 1 Oden Eriksson 2017-01-04 16:26:26 UTC
Proposed and verified fix is here:

https://github.com/nagios-plugins/nagios-plugins/commit/367a44187db1c18a9fd4ba5fafe844f80cbb03c5

Comment 2 Scott Wilkerson 2017-01-04 17:14:44 UTC
*** Bug 1410055 has been marked as a duplicate of this bug. ***

Comment 3 Anand Buddhdev 2017-01-08 15:09:20 UTC
So when is this package going to be fixed in EPEL? Could one of the maintainers just patch in the fix in the SPEC and make a new release? There's no information on when upstream will release a fix, and this check remains broken for all of CentOS 6!

Comment 4 Ben Webb 2017-01-10 23:04:48 UTC
Note this breaks on CentOS 7 too. A simple fix that works for me is to comment out line 80, which quotes the filename:

# $opt_f = '"' . $opt_f . '"';

Comment 5 Ben Webb 2017-01-10 23:07:44 UTC
Correction, CentOS 7 seems OK if you're using the stock /usr/bin/perl (the bug only occurs with older Perl).

Comment 6 Anand Buddhdev 2017-01-13 08:19:33 UTC
Hello maintainers,

This is a high to urgent severity bug! Could one of you please tell us what you're doing to resolve it? Surely you're not just sitting around waiting for upstream to release a new version?

Remember that ALL our Icinga checks are affected by this!!

Comment 7 Oden Eriksson 2017-01-13 09:28:09 UTC
Need help maintaining nagios* ?

Comment 8 Anand Buddhdev 2017-01-13 09:40:04 UTC
Hi Oden,

If your comment was in jest, then I smile :)

If you were serious, then I thank you for the offer, but we don't need help. We have applied a sledgehammer fix that has made the file_age plugin work again. It involves deleting the offending line from the plugin, using our config management system (Ansible). Nevertheless, it's additional complexity.

In my opinion, a package that BREAKS things, should be very quickly updated. Otherwise it makes us lose faith in auto-updating from EPEL. In my opinion, 9 days to too long. I expected a fix to appear within a couple of days of this report.

Comment 9 Oden Eriksson 2017-01-13 11:41:23 UTC
(In reply to Anand Buddhdev from comment #8)
> Hi Oden,
> 
> If your comment was in jest, then I smile :)
> 
> If you were serious, then I thank you for the offer, but we don't need help.

It was aimed at RH EPEL in general. I maintained nagios* for many years in Mandriva Linux and did the mega split of nagios-plugins long before this package was split.

Note. Mageia was forked 2010 an the split was done long prior that.

https://svnweb.mageia.org/packages/cauldron/nagios-plugins/current/SPECS/nagios-plugins.spec?revision=1078890&view=markup

Well.

Comment 10 Anand Buddhdev 2017-01-17 11:24:16 UTC
Hello. Could one of the maintainers please provide an update of what they intend to do to fix this issue?

Comment 11 Stephen John Smoogen 2017-01-17 14:24:23 UTC
I am taking this bug and will be putting out a fix as soon as I look over the proposed ones. 

Oden and Anand, please do me a favor and review the packages at 

https://copr.fedorainfracloud.org/coprs/smooge/Nagios_Update/

This is where I will be doing the 'fixes' and updated for moving the plugins and other tools. Oden since you helped maintain Nagios for Mandriva I would appreciate any tips and work you can help me with as I am doing this as an "I need to get you guys and myself working"

Comment 12 Scott Wilkerson 2017-01-17 14:55:39 UTC
Stephen,

As an FYI, upstream is coming out with an new version that has this and a few others fixed very shortly.

Comment 13 Stephen John Smoogen 2017-01-17 17:13:42 UTC
Is there a git repo and commit that I can point to for this?

Comment 14 Matthias Hensler 2017-01-17 17:30:12 UTC
The upstream commitfix is here: https://github.com/nagios-plugins/nagios-plugins/commit/367a44187db1c18a9fd4ba5fafe844f80cbb03c5

Comment 15 Fedora Update System 2017-01-18 01:56:21 UTC
nagios-plugins-2.1.4-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-3baea4e0e4

Comment 16 Fedora Update System 2017-01-18 02:06:12 UTC
nagios-plugins-2.1.4-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-99cefd5950

Comment 17 Fedora Update System 2017-01-18 02:22:38 UTC
nagios-plugins-2.1.4-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60884752c4

Comment 18 Fedora Update System 2017-01-18 02:35:42 UTC
nagios-plugins-2.1.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-54fcdfe5a7

Comment 19 Scott Wilkerson 2017-01-18 13:39:18 UTC
*** Bug 1414243 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2017-01-19 07:23:06 UTC
nagios-plugins-2.1.4-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-60884752c4

Comment 21 Fedora Update System 2017-01-19 09:10:42 UTC
nagios-plugins-2.1.4-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-54fcdfe5a7

Comment 22 Fedora Update System 2017-01-19 20:47:28 UTC
nagios-plugins-2.1.4-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-3baea4e0e4

Comment 23 Fedora Update System 2017-01-19 20:50:42 UTC
nagios-plugins-2.1.4-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-99cefd5950

Comment 24 Christoph Galuschka 2017-01-20 06:42:00 UTC
nagios-plugins-2.1.4-3.el6 fixes the issue on my system. Thanks!

Comment 25 Anand Buddhdev 2017-01-20 08:33:48 UTC
I also confirm that this -3 release fixes the check_file_age plugin on our CentOS 6 systems.

Please release to epel.

Comment 26 Fedora Update System 2017-01-20 20:48:16 UTC
nagios-plugins-2.1.4-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2017-02-15 14:42:34 UTC
nagios-plugins-2.1.4-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-0430ba2927

Comment 28 Fedora Update System 2017-02-15 15:46:13 UTC
nagios-plugins-2.1.4-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e7272b1cd

Comment 29 Fedora Update System 2017-02-16 17:18:57 UTC
nagios-plugins-2.1.4-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-0430ba2927

Comment 30 Fedora Update System 2017-02-16 20:59:42 UTC
nagios-plugins-2.1.4-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-4bf2c82fc6

Comment 31 Fedora Update System 2017-02-16 23:31:04 UTC
nagios-plugins-2.1.4-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d35ac726be

Comment 32 Fedora Update System 2017-02-17 15:25:57 UTC
nagios-plugins-2.1.4-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e7272b1cd

Comment 33 Fedora Update System 2017-02-17 21:19:15 UTC
nagios-plugins-2.1.4-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d35ac726be

Comment 34 Fedora Update System 2017-02-25 21:47:32 UTC
nagios-plugins-2.2.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-cbb077cc9b

Comment 35 Fedora Update System 2017-02-25 22:36:19 UTC
nagios-plugins-2.2.0-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-579895db6a

Comment 36 Fedora Update System 2017-02-26 22:49:45 UTC
nagios-plugins-2.2.0-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-579895db6a

Comment 37 Fedora Update System 2017-03-11 01:03:37 UTC
nagios-plugins-2.2.0-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-212f3ef76e

Comment 38 Fedora Update System 2017-03-11 12:50:39 UTC
nagios-plugins-2.2.0-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-212f3ef76e

Comment 39 Fedora Update System 2017-03-13 00:38:45 UTC
nagios-plugins-2.2.0-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-756fbbf351

Comment 40 Fedora Update System 2017-03-14 00:19:27 UTC
nagios-plugins-2.2.0-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-756fbbf351

Comment 41 Fedora Update System 2017-04-20 23:57:37 UTC
nagios-plugins-2.2.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d5fc1e5e5c

Comment 42 Fedora Update System 2017-04-21 00:09:29 UTC
nagios-plugins-2.2.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e452ab1676

Comment 43 Fedora Update System 2017-04-22 21:48:38 UTC
nagios-plugins-2.2.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e452ab1676

Comment 44 Fedora Update System 2017-04-23 17:20:46 UTC
nagios-plugins-2.2.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d5fc1e5e5c

Comment 45 Fedora Update System 2017-06-29 23:49:32 UTC
nagios-plugins-2.1.4-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 46 Fedora Update System 2017-06-30 00:49:04 UTC
nagios-plugins-2.2.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 47 Fedora Update System 2017-06-30 03:17:52 UTC
nagios-plugins-2.2.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.