Bug 1414262 - Remove 'update-from-vip' from example in docs.
Summary: Remove 'update-from-vip' from example in docs.
Keywords:
Status: CLOSED DUPLICATE of bug 1456897
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 11.0 (Ocata)
Assignee: Dan Macpherson
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 08:12 UTC by Harald Jensås
Modified: 2020-06-11 13:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 17:04:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Harald Jensås 2017-01-18 08:12:39 UTC
Description of problem:
The inclusion of 'update-from-vip' is confusing in the doc example.

The 'update-from-vip' is only relevant when doing and update from OSP7.1 to 7.2 or greater.
Ref:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html-single/Director_Installation_and_Usage/index.html#sect-Version_Specific_Notes

Version-Release number of selected component (if applicable):
https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/single/upgrading-red-hat-openstack-platform/#sect-Updating_the_Overcloud

Actual results:
User read the documentation, and see an environment file with 'update' in its name and believe it is a requirement to include this during updates.

Because this is included, the update fails and leave the stack in "UPDATE_FAILED" state.

Expected results:
The OSP8 documentation should not have an example referencing an OSP7 specific environment file.

Additional info:

Comment 1 Amit Ugol 2017-03-08 10:16:46 UTC
@ Dan, Hi, do you need any info from eng. side?

Comment 3 Lucy Bopf 2017-05-26 06:47:03 UTC
Assigning to Martin for review.

Martin, looks like the update-from-vip environment file exists in docs for versions 8 and higher, and should be removed.

Comment 4 Sofer Athlan-Guyot 2017-05-30 10:52:34 UTC
Hi,

this one https://bugzilla.redhat.com/show_bug.cgi?id=1454710 is for osp9 documentation.

Comment 5 Dan Macpherson 2017-05-30 17:04:22 UTC
I've updated this one as a part of BZ#1456897

*** This bug has been marked as a duplicate of bug 1456897 ***


Note You need to log in before you can comment on or make changes to this bug.