Bug 1454710 - Minor upgrades on OSP9 references a yaml file that does not exist
Summary: Minor upgrades on OSP9 references a yaml file that does not exist
Keywords:
Status: CLOSED DUPLICATE of bug 1456897
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Martin Lopes
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-23 11:29 UTC by Yolanda Robla
Modified: 2017-06-05 11:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 17:04:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yolanda Robla 2017-05-23 11:29:21 UTC
Description of problem:

Following the documentation on OSP9 for minor upgrades, on https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/9/html/upgrading_red_hat_openstack_platform/sect-updating_the_environment.

On the section "updating the overcloud packages", it mentions:

  -e /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-vip.yaml \

This file does not exist for Mitaka. In updates, i only can see update-from-keystone-admin-internal-api.yaml  update-from-publicvip-on-ctlplane.yaml  .

Either the file is missing, or it needs to use another one (update-from-publicvip-on-ctlplane.yaml ?)

Comment 1 Yolanda Robla 2017-05-23 12:59:09 UTC
Looking at the README.md in the updates directory:

This directory contains Heat environment file snippets which can
be used to ensure smooth updates of the Overcloud.

Contents
--------

**update-from-keystone-admin-internal-api.yaml**
  To be used if the Keystone Admin API was originally deployed on the
  Internal API network.

**update-from-publicvip-on-ctlplane.yaml**
  To be used if the PublicVirtualIP resource was deployed as an additional VIP on the 'ctlplane'.


So documentation really shall reflect the contents of this README. It shall mention both files, and explain which file to use on each case.

Comment 2 Sofer Athlan-Guyot 2017-05-30 10:38:40 UTC
Hi Yolanda,

yes, some documentation here could be added to make the user aware of the change in the templates.  I'm switching this to low as the command is only an example.

Hi Marios,

back in the day you worked on this one https://review.openstack.org/#/c/255929/.  Maybe you could clarify easily which one is needed when.  It's not that obvious just looking at the commit and the code.

Comment 3 Sofer Athlan-Guyot 2017-05-30 10:51:54 UTC
Hi, just to match version I'll keep this one open but it's clearly a "duplicate" of https://bugzilla.redhat.com/show_bug.cgi?id=1414262 which is for osp8.  Matching the assignment for awareness.

Comment 4 Dan Macpherson 2017-05-30 17:04:33 UTC
I've updated this one as a part of BZ#1456897

*** This bug has been marked as a duplicate of bug 1456897 ***

Comment 5 Marios Andreou 2017-06-05 11:47:57 UTC
(In reply to Sofer Athlan-Guyot from comment #2)
> Hi Yolanda,
> 
> yes, some documentation here could be added to make the user aware of the
> change in the templates.  I'm switching this to low as the command is only
> an example.
> 
> Hi Marios,
> 
> back in the day you worked on this one
> https://review.openstack.org/#/c/255929/.  Maybe you could clarify easily
> which one is needed when.  It's not that obvious just looking at the commit
> and the code.

Hi, looking at comment #0 the 'original' update-from-vip.yaml was for OSP7 I believe (++ it should be removed from the docs example) and the one you are pointing at was for OSP9/mitaka. In that particular case it was to be used if your original deployment had keystone admin on the internal api network rather than on the ctlplane (as we still do today by default like https://github.com/openstack/tripleo-heat-templates/blob/cbd528f4115468cd17109c89c3a7ca7b21262848/network/service_net_map.j2.yaml#L49 )

sorry to miss the needinfo Sofer as you know I was out all of last week ;)


Note You need to log in before you can comment on or make changes to this bug.