Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414346 - Quota: After upgrade from 3.7 to higher version , gluster quota list command shows "No quota configured on volume repvol"
Summary: Quota: After upgrade from 3.7 to higher version , gluster quota list command ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1412955
TreeView+ depends on / blocked
 
Reported: 2017-01-18 10:22 UTC by Sanoj Unnikrishnan
Modified: 2017-05-30 18:38 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1412955
: 1450767 1450773 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:38:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-18 10:34:36 UTC
REVIEW: http://review.gluster.org/16425 (Fixes upgrade issue in quota.conf) posted (#1) for review on master by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 2 Worker Ant 2017-01-19 07:19:09 UTC
REVIEW: http://review.gluster.org/16425 (Fixes upgrade issue in quota.conf) posted (#2) for review on master by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 3 Worker Ant 2017-01-19 13:29:29 UTC
COMMIT: http://review.gluster.org/16425 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 89cf743118ab6554c7f210754e51c4921cbb60c7
Author: Sanoj Unnikrishnan <sunnikri@redhat.com>
Date:   Wed Jan 18 15:56:00 2017 +0530

    Fixes upgrade issue in quota.conf
    
    When an op-version bump up is done the glusterd_store_quota_config
    upgrades the quota conf file, although overwriting the same later
    which leaves out all gfid entries. While this is warranted for
    enable opcode, for upgrade we need to retain gfids. So for upgrade
    opcode, we return once the upgrade is done.
    
    Change-Id: I2b38c6022d74b4a14dc07432651a51cc39ad5120
    BUG: 1414346
    Signed-off-by: Sanoj Unnikrishnan <sunnikri@redhat.com>
    Reviewed-on: http://review.gluster.org/16425
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 4 Worker Ant 2017-05-15 07:29:07 UTC
REVIEW: https://review.gluster.org/17291 (Fixes upgrade issue in quota.conf) posted (#1) for review on release-3.8 by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 5 Shyamsundar 2017-05-30 18:38:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.