Bug 1414566 - EAP Quickstart App is not accessible
Summary: EAP Quickstart App is not accessible
Keywords:
Status: CLOSED DUPLICATE of bug 1414960
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 20:53 UTC by Vikas Laad
Modified: 2017-02-13 14:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 18:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
deploy log (26.41 KB, text/plain)
2017-01-19 18:47 UTC, Vikas Laad
no flags Details

Description Vikas Laad 2017-01-18 20:53:27 UTC
Description of problem:
EAP App is not accessible using route.

Version-Release number of selected component (if applicable):
openshift v3.5.0.5+8f2840d
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0


How reproducible:
Always

Steps to Reproduce:
1. Create OCP 3.5 env
2. oc new-project vlaad34
3. oc create -f https://raw.githubusercontent.com/jboss-openshift/application-templates/master/secrets/eap-app-secret.json
4. oc new-app --template=eap64-mysql-s2i

After the build is done and application is deployed, curl command return no output on the route.

curl on the <svc-ip>:8080 also returns nothing.


Actual results:
Application access failed

Expected results:
Should show app home page, TODO list

Additional info:

Comment 1 kconner 2017-01-19 17:55:25 UTC
Where are the logs of the deployment?

Comment 2 Vikas Laad 2017-01-19 18:34:48 UTC
Deployment log has following lines

root@ip-172-31-41-173: ~/svt/openshift_scalability # oc logs eap-app-1-deploy -f
--> Scaling eap-app-1 to 1
--> Waiting up to 10m0s for pods in rc eap-app-1 to become ready
--> Success

Build logs

root@ip-172-31-41-173: ~/svt/openshift_scalability # oc logs eap-app-1-build -f
Cloning "https://github.com/jboss-openshift/openshift-quickstarts" ...
        Commit: caec20220374804b2cb3d3622a754f9091af7c57 (Fixed bug: summary is displayed instead of description (cherry picked from com..)
        Author: Marko Luksa <marko.luksa@gmail.com>
        Date:   Tue Feb 9 22:55:09 2016 +0100
Pulling image "registry.access.redhat.com/jboss-eap-6/eap64-openshift@sha256:ee2a1ba5ad72e9ac2cc8e800a280ea6f60f9b3920f5d0fcde9ad15724eb372f2" ...
Pulling image "registry.access.redhat.com/jboss-eap-6/eap64-openshift@sha256:ee2a1ba5ad72e9ac2cc8e800a280ea6f60f9b3920f5d0fcde9ad15724eb372f2" ...
Copying all war artifacts from /home/jboss/source/. directory into /opt/eap/standalone/deployments for later deployment...
Copying all ear artifacts from /home/jboss/source/. directory into /opt/eap/standalone/deployments for later deployment...
Copying all rar artifacts from /home/jboss/source/. directory into /opt/eap/standalone/deployments for later deployment...
Copying all jar artifacts from /home/jboss/source/. directory into /opt/eap/standalone/deployments for later deployment...
Copying all war artifacts from /home/jboss/source/deployments directory into /opt/eap/standalone/deployments for later deployment...
Copying all ear artifacts from /home/jboss/source/deployments directory into /opt/eap/standalone/deployments for later deployment...
Copying all rar artifacts from /home/jboss/source/deployments directory into /opt/eap/standalone/deployments for later deployment...
Copying all jar artifacts from /home/jboss/source/deployments directory into /opt/eap/standalone/deployments for later deployment...

Pushing image 172.27.21.227:5000/vlaadeap/eap-app:latest ...
Pushed 0/7 layers, 1% complete
Pushed 1/7 layers, 17% complete
Pushed 2/7 layers, 30% complete
Pushed 3/7 layers, 48% complete
Pushed 4/7 layers, 77% complete
Pushed 5/7 layers, 90% complete
Pushed 6/7 layers, 96% complete
Pushed 7/7 layers, 100% complete
Push successful

Comment 3 Vikas Laad 2017-01-19 18:47:54 UTC
Created attachment 1242546 [details]
deploy log

Comment 4 kconner 2017-01-23 18:43:49 UTC
Strange, for some reason this is not building the application as I would expect.  Has something changed in the S2I process for OCP 3.5?

If it's checking out the correct source then it should discover a pom.xml and begin the maven build process as below


Pulling image
"ce-registry.usersys.redhat.com/jboss-eap-6/eap64-openshift@sha256:f8ae0512065a1b04a40ea1ff8df7160c491bb8bc76a3354f216a662ce7034330"
...
Pulling image
"ce-registry.usersys.redhat.com/jboss-eap-6/eap64-openshift@sha256:f8ae0512065a1b04a40ea1ff8df7160c491bb8bc76a3354f216a662ce7034330"
...
Cloning "https://github.com/jboss-openshift/openshift-quickstarts" ...
	Commit:	caec20220374804b2cb3d3622a754f9091af7c57 (Fixed bug: summary is displayed instead of description (cherry picked
from com..)
	Author:	Marko Luksa <marko.luksa@gmail.com>
	Date:	Tue Feb 9 22:55:09 2016 +0100

Found pom.xml... attempting to build with 'mvn -e -Popenshift -DskipTests -Dcom.redhat.xpaas.repo.redhatga package

Comment 5 kconner 2017-01-23 18:45:32 UTC
BTW what does 'no output' mean?  Are you getting any response at all?

Comment 6 Ben Parees 2017-01-23 18:47:38 UTC

*** This bug has been marked as a duplicate of bug 1414960 ***


Note You need to log in before you can comment on or make changes to this bug.