Bug 1414960 - contextDir is ignored during S2I builds
Summary: contextDir is ignored during S2I builds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Vikas Laad
URL:
Whiteboard: aos-scalability-35
: 1414566 1414861 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 20:05 UTC by jmencak
Modified: 2017-07-24 14:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 04:09:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description jmencak 2017-01-19 20:05:59 UTC
Description of problem:
contextDir is ignored when fetching from a git repository.

Version-Release number of selected component (if applicable):
# oc version
oc v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-31-16-51.us-west-2.compute.internal:8443
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4

How reproducible:
always

Steps to Reproduce:
1. oc new-project eap64

2. wget https://raw.githubusercontent.com/openshift/svt/master/openshift_scalability/content/quickstarts/eap/eap64-mysql.json

3. oc process -f eap64-mysql.json | oc create -f-

4. oc get pods
NAME                    READY     STATUS      RESTARTS   AGE
eap-app-1-7hp50         1/1       Running     0          4m
eap-app-1-build         0/1       Completed   0          6m
eap-app-mysql-1-48vd5   1/1       Running     0          6m

5. oc get route
NAME             HOST/PORT                                               PATH      SERVICES         PORT      TERMINATION
eap-app          eap-app-eap64.router.default.svc.cluster.local                    eap-app          <all>
secure-eap-app   secure-eap-app-eap64.router.default.svc.cluster.local             secure-eap-app   <all>     passthrough


Actual results:
$ oc exec eap-app-1-7hp50 -- ls /tmp/src
README.md
datagrid
decisionserver
helloworld-mdb
kitchensink-managed-ds
kitchensink-mongodb
settings.xml
todolist
tomcat-jdbc
tomcat-websocket-chat

$ curl -I eap-app-eap64.router.default.svc.cluster.local
HTTP/1.1 404 Not Found
Server: Apache-Coyote/1.1
Content-Length: 0
Date: Thu, 19 Jan 2017 19:58:39 GMT
Set-Cookie: d6491ff8aac7a15ec6bc2b78b690ae1e=5a80edef759869b002f1b52c3d3ccd5d; path=/; HttpOnly


Expected results:
$ oc exec eap-app-1-7hp50 -- ls /tmp/src
pom.xml
src

$ curl -I eap-app-eap64.router.default.svc.cluster.local
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Content-Type: text/html;charset=UTF-8
Content-Length: 2005
Date: Thu, 19 Jan 2017 20:03:12 GMT
Set-Cookie: d6491ff8aac7a15ec6bc2b78b690ae1e=fa8b97780776744bd4302c225730443d; path=/; HttpOnly
Cache-control: private


Additional info:

Comment 1 Ben Parees 2017-01-20 14:55:58 UTC
this is actually pretty bad(and a regression), raising severity.

Comment 2 Ben Parees 2017-01-23 18:47:38 UTC
*** Bug 1414566 has been marked as a duplicate of this bug. ***

Comment 3 Ben Parees 2017-01-24 00:22:51 UTC
https://github.com/openshift/origin/pull/12628

Comment 4 Ben Parees 2017-01-24 02:56:54 UTC
*** Bug 1414861 has been marked as a duplicate of this bug. ***

Comment 5 Troy Dawson 2017-01-27 17:33:24 UTC
This has been merged into ocp and is in OCP v3.5.0.10 or newer.

Comment 6 Vikas Laad 2017-01-27 20:50:27 UTC
Verified in following release 

openshift v3.5.0.10+e377fa2
kubernetes v1.5.2+43a9be4
etcd 3.1.0


I can curl the url
# oc exec eap-app-1-bdsjb -- ls /tmp/src
README.md
datagrid
decisionserver
helloworld-mdb
kitchensink-managed-ds
kitchensink-mongodb
pom.xml
settings.xml
src
todolist
tomcat-jdbc
tomcat-websocket-chat

root@ip-172-31-1-243: ~ # curl -I eap-app-vlaad.0127-jzz.qe.rhcloud.com
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Content-Type: text/html;charset=UTF-8
Content-Length: 2005
Date: Fri, 27 Jan 2017 20:38:20 GMT
Set-Cookie: e057d9c1deb5bf7c9fe39e819f5c6d1f=369c7a3ede32feb7e7a34ff14e40331a; path=/; HttpOnly
Cache-control: private

Comment 7 jmencak 2017-01-31 11:43:20 UTC
I can confirm this is fixed in

oc v3.5.0.10+e377fa2
kubernetes v1.5.2+43a9be4

Thanks.

Comment 8 errata-xmlrpc 2017-04-12 19:10:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.