Bug 1414784 - Can't upgrade keystone before upgrading the repository
Summary: Can't upgrade keystone before upgrading the repository
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Dan Macpherson
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
: 1392613 1414917 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 12:39 UTC by Amit Ugol
Modified: 2020-04-15 15:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 08:02:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2750961 0 None None None 2018-01-07 10:47:37 UTC

Description Amit Ugol 2017-01-19 12:39:46 UTC
Description of problem:
Upgrading RHOS 8 to 9, the online guide says to upgrade the keystone component and after that to upgrade the upgrade scripts, meaning that puppet is being run with older templates and configurations where it should be running against a newer set of resources fetched when upgrading the scripts.

See steps 3.4.3 and 3.4.4 here:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/paged/upgrading-red-hat-openstack-platform/chapter-3-director-based-environments-performing-upgrades-to-major-versions

Comment 1 Sofer Athlan-Guyot 2017-01-24 19:23:07 UTC
So this one is kind of a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1414917 and of https://bugzilla.redhat.com/show_bug.cgi?id=1388146 

After discussing with the developer of the liberty to mitaka keystone migration, the template is meant to be run with previous puppet module in place.  This is how I successfully upgrade osp8->osp9, skipping altogether this step:


    $ for i in $(nova list|grep ctlplane|awk -F' ' '{ print $12 }'|awk -F'=' '{  print $2 }'); do ssh -o StrictHostKeyChecking=no heat-admin@$i "sudo yum -y update openstack-puppet-modules" ; done

At least another deployment was done without using this step neither.

In my opinion we have to remove this step (the upgrade of puppet module) because:
 - it cannot work until we have installed the new repository (the init step)
 - the upgrade is working without it (and we reason as it has no effect)

Comment 2 Sofer Athlan-Guyot 2017-01-24 19:26:37 UTC
*** Bug 1414917 has been marked as a duplicate of this bug. ***

Comment 3 Sofer Athlan-Guyot 2017-01-26 18:06:43 UTC
Oki,

this is actually more than just a documentation problem.  If you do upgrade the puppet-modules before doing the keystone migration then it fails with:

    Error: /Stage[main]/Keystone/Exec[keystone-manage bootstrap]: Failed to call refresh: keystone-manage bootstrap --bootstrap-password 39EnVE8U7QaxGXYzpKhH47kXh returned 2 instead of one of [0]
    Error: /Stage[main]/Keystone/Exec[keystone-manage bootstrap]: keystone-manage bootstrap --bootstrap-password 39EnVE8U7QaxGXYzpKhH47kXh returned 2 instead of one of [0]

So we have to remove this step.

Comment 6 Dan Macpherson 2017-02-23 08:01:24 UTC
No response in over two weeks. If nothing further to add, I'll close this BZ.

If further changes are required, please feel free to reopen it.

Comment 7 Sofer Athlan-Guyot 2017-03-05 23:27:23 UTC
Hi Dan,

nope that's fine, thanks.

Comment 8 Sofer Athlan-Guyot 2017-03-08 11:20:19 UTC
*** Bug 1392613 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.