Bug 1414790 - [UPDATES] Stack update fails with Deployment exited with non-zero status code: 3
Summary: [UPDATES] Stack update fails with Deployment exited with non-zero status code: 3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Lukas Bezdicka
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1394025
TreeView+ depends on / blocked
 
Reported: 2017-01-19 12:58 UTC by Yurii Prokulevych
Modified: 2017-05-17 19:41 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170303152752.0rc1.el7ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1475381 (view as bug list)
Environment:
Last Closed: 2017-05-17 19:41:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 422610 None None None 2017-01-19 16:36:43 UTC
Launchpad 1656980 None None None 2017-01-19 12:58:44 UTC

Description Yurii Prokulevych 2017-01-19 12:58:44 UTC
Description of problem:
-----------------------

Attempt to update packages on overcloud fails:
yes '' | openstack overcloud update stack -i overcloud
...
update finished with status FAILED
Stack update failed.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-heat-templates-0.0.1-0.20170109231310.01b1768.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-0.20170116025719.fa45e05.el7ost.noarch

Steps to Reproduce:
1. Setup latest repos on overcloud
2. Run 'openstack overcloud update stack -i overcloud'
3.

Actual results:
---------------
Stack update fails.

Additional info:
----------------
Virtual setup: 3controllers + 1compute + 3ceph

Comment 3 Yurii Prokulevych 2017-04-07 13:24:39 UTC
Verified with openstack-tripleo-heat-templates-6.0.0-3.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 19:41:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.