Bug 1414861 - JWS MongoDB app route not accessible
Summary: JWS MongoDB app route not accessible
Keywords:
Status: CLOSED DUPLICATE of bug 1414960
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 15:40 UTC by Vikas Laad
Modified: 2017-01-24 02:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 02:56:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
deploy logs (6.26 KB, text/plain)
2017-01-20 14:27 UTC, Vikas Laad
no flags Details

Description Vikas Laad 2017-01-19 15:40:51 UTC
Description of problem:
Creating JWS MongoDB app in Openshift 3.5 is not accessible.

Version-Release number of selected component (if applicable):
openshift v3.5.0.5+8f2840d
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0

How reproducible:
Always

Steps to Reproduce:
1. oc new-project test
2. oc create -f https://raw.githubusercontent.com/jboss-openshift/application-templates/master/secrets/jws-app-secret.json
3. oc new-app --template=openshift/jws30-tomcat7-mongodb-s2i

after the build and deploy runs successfully curl on route or svc returns blank
root@ip-172-31-41-173: ~/svt/openshift_scalability # oc get pods
NAME                      READY     STATUS      RESTARTS   AGE
jws-app-1-build           0/1       Completed   0          11m
jws-app-1-k6n6g           1/1       Running     0          10m
jws-app-mongodb-1-mhx66   1/1       Running     0          11m


root@ip-172-31-41-173: ~/svt/openshift_scalability # oc get routes
NAME             HOST/PORT                                         PATH      SERVICES         PORT      TERMINATION
jws-app          jws-app-vlaadjws.0118-soa.qe.rhcloud.com                    jws-app          <all>     
secure-jws-app   secure-jws-app-vlaadjws.0118-soa.qe.rhcloud.com             secure-jws-app   <all>     passthrough

root@ip-172-31-41-173: ~/svt/openshift_scalability # curl jws-app-vlaadjws.0118-soa.qe.rhcloud.com

root@ip-172-31-41-173: ~/svt/openshift_scalability # oc get svc
NAME              CLUSTER-IP       EXTERNAL-IP   PORT(S)     AGE
jws-app           172.26.144.93    <none>        8080/TCP    12m
jws-app-mongodb   172.26.154.233   <none>        27017/TCP   12m
secure-jws-app    172.26.57.136    <none>        8443/TCP    12m

root@ip-172-31-41-173: ~/svt/openshift_scalability # curl 172.26.144.93:8080


Actual results:
No response from app route

Expected results:
No response from app route, it should return the TODO list page


Additional info:

Comment 1 Vikas Laad 2017-01-20 14:27:41 UTC
Created attachment 1242824 [details]
deploy logs

Comment 2 kconner 2017-01-24 01:53:18 UTC
Ben I'm guessing this is another duplicate of the OpenShift issue although there are no build logs to confirm.

Comment 3 Ben Parees 2017-01-24 02:56:54 UTC
Yeah, certainly looks like it.  Any s2i build that uses a context dir would be impacted by 1414960.

*** This bug has been marked as a duplicate of bug 1414960 ***


Note You need to log in before you can comment on or make changes to this bug.