Bug 1414961 - dnf fails to update mkvtoolnix packages from local RPMs
Summary: dnf fails to update mkvtoolnix packages from local RPMs
Status: CLOSED DUPLICATE of bug 1263888
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 20:13 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2017-01-19 20:33 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-19 20:19:08 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2017-01-19 20:13:47 UTC
Description of problem:
dnf is unable to perform a simple update of two mkvtoolnix packages. Using rpm directly poses no issues.

Version-Release number of selected component (if applicable):
dnf-1.1.10-4.fc25.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Ensure mkvtoolnix{,-gui}-9.6.0-1.fc25 are installed
2. dnf upgrade ./mkvtoolnix-9.7.1-1.fc25.x86_64.rpm ./mkvtoolnix-gui-9.7.1-1.fc25.x86_64.rpm 

Actual results:
Last metadata expiration check: 5:50:37 ago on Thu Jan 19 15:19:28 2017.
Error: package mkvtoolnix-gui-9.7.1-1.fc25.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)

Expected results:
Packages should be successfully updated.

Additional info:
# rpm -Uvh mkvtoolnix-gui-9.7.1-1.fc25.x86_64.rpm mkvtoolnix-9.7.1-1.fc25.x86_64.rpm 
Preparing...                          ################################# [100%]
Updating / installing...
   1:mkvtoolnix-9.7.1-1.fc25          ################################# [ 25%]
   2:mkvtoolnix-gui-9.7.1-1.fc25      ################################# [ 50%]
Cleaning up / removing...
   3:mkvtoolnix-gui-9.6.0-1.fc25      ################################# [ 75%]
   4:mkvtoolnix-9.6.0-1.fc25          ################################# [100%]

Comment 1 Igor Gnatenko 2017-01-19 20:19:08 UTC

*** This bug has been marked as a duplicate of bug 1263888 ***

Comment 2 Dominik 'Rathann' Mierzejewski 2017-01-19 20:33:31 UTC
Here are the 9.7.1 RPMs: https://koji.fedoraproject.org/koji/taskinfo?taskID=17332776 (Once it finishes building).


Note You need to log in before you can comment on or make changes to this bug.